nsIURIChecker asyncCheck never returns with unexisting file:// URI

RESOLVED DUPLICATE of bug 297865

Status

()

--
critical
RESOLVED DUPLICATE of bug 297865
13 years ago
13 years ago

People

(Reporter: marja, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050613

I call nsIURIChecker asyncCheck() from javascript to check the URI does not yet
exists

when the URI is http:// URI or an existing file:// URI it calls onStartRequest
but if URI is an unexisting file:// URI it never calls onStartRequest and never
returns

Reproducible: Always

Steps to Reproduce:
1. call asyncCheck with an unexisting file:// URI
2. see if onStartRequest is called
3.

Actual Results:  
onStartRequest does not get called

Expected Results:  
call onStartRequest

*** This bug has been marked as a duplicate of 297865 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.