autocomplete with ldap should use DisplayName, not the cn

RESOLVED DUPLICATE of bug 241220

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 241220
13 years ago
13 years ago

People

(Reporter: Peter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)
Build Identifier: 

For example: You have Peter Smith and Andrew Smith in an ldap-directory. They 
log in (account name) as SMITH1 and SMITH2 (cn). If you type Smith, the 
AutoComplete will show SMITH1 <emailaddress> in the mailto field, if you select 
this one. 


Reproducible: Always

Steps to Reproduce:
1.Open the compose window
2.Type SMITH in the mailto field
3.

Actual Results:  
there are two proposals:
SMITH1 <andrew.smith@foo.com>
SMITH2 <peter.smith@foo.com>

Expected Results:  
two proposals should appear:
Andrew Smith <andrew.smith@foo.com>
Peter Smith <peter.smith@foo.com>

Only if DisplayName was not found, then the cn should be used.

If you use the search function in the contacts sidebar and search SMITH1, the 
mailto field will show you Peter Smith <emailaddress>.

Comment 1

13 years ago
Related to/duplicate of Core bug 241220?
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 241220 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.