Closed Bug 297907 Opened 19 years ago Closed 19 years ago

hyperlink to target incorrect when graphics on page

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 60307

People

(Reporter: ve3ll, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.8) Gecko/20050511

normally hyperlinking to a target on a different page places that target in
upper left corner of screen. However when a page contains images, the display
is not correct. Most likely calculation of displacement due to graphic was
not completed before jump was made -- SEQUENCING ISSUE not present in browsers
other than mozilla and firefox. The jumps are aok on pages without images.
Not tested on pages where images have heights defined in image element but
that is rarely done by designers even though it is more efficient.

Reproducible: Always

Steps to Reproduce:
1. move to updates section of given url
2. select the java fileio topic for june 16
3. note that topic start is mid screen
4. observe in MSIE, Opera, Amaya etc for desired effect

Actual Results:  
poorly positioned topic element

Expected Results:  
referenced element should be in upper left corner 
similar to other browsers and to action in mozilla
if no graphics are on page ...

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.