Closed Bug 297918 Opened 17 years ago Closed 6 years ago

songtouch.com - rejects non Firefox Gecko browsers

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: rderuiter, Unassigned)

References

()

Details

(Whiteboard: [country-us] [needanalysis])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Pressing any navigate button on www.songtouch.com/welcom.aspx redirects browser
to (www.songtouch.com/spages/browser.htm) and displays message " The website you
are trying to access can only be viewed using Internet Explorer Version 5.5 or
above" (with a link to download IE). No other navigation is possible with FF. 

Reproducible: Always

Steps to Reproduce:
1. Enter www.songtouch.com in the Firefox navigate bar. You go to
http://www.songtouch.com/welcom.aspx
2. Click on the "register now" or "just browse" buttons.
3. 

Actual Results:  
Navigation begins but redirects to http://www.songtouch.com/spages/browser.htm,
with the message displayed above (in "Details"). No other navigation on the site
is permitted, not even by manually inserting a site URL (by copy/paste) as seen
in IE.

Expected Results:  
I would expect to be able to navigate the site as in IE.
(The problem is with the site, not with FF, as far as I can tell.)

Probably related to the site it connects to: www.passalong.com (which also
blocks in the same way/same message. Report made for that site here as well.)
confirmed. please contact them and ask them to support mozilla firefox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: www.songtouch.com allows only IE 5.5 or above to display any page but the welcome page. → songtouch.com - allows only IE 5.5 or above to display any page but the welcome page.
# This website can only be viewed on:  Internet Explorer version 5.5 or above.
# Netscape 7.1 or 7.2.
# Firefox 1.0.1 and above.
Blocks: geckoisgecko
Summary: songtouch.com - allows only IE 5.5 or above to display any page but the welcome page. → songtouch.com - rejects non Firefox Gecko browsers
The reject message is the same as bug 297917 , marking as dupe
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297917
Actually, I get a different message here:

http://musicstore.songtouch.com/mac.htm

"The website you are trying to access can only be viewed in Windows operating systems."

If I spoof as Firefox on XP, I get this:

http://musicstore.songtouch.com/InstallPlugins.aspx?index=yes

"SongTouch.com uses ActiveX for some of our site features. In order to get the full SongTouch experience you'll need to install ActiveX plug-ins for Firefox.

This easy 3 part process will only take a moment:

1. Click on the button below to install the ActiveX plug-ins for Firefox.

2. You will be taken to our install shield page, where our software/plug-in installation will take place.

3. Upon installation, close and restart ALL Firefox browser window(s).  

Of course you don't need to do anything to browse SongTouch. But you'll need to install the plug-in in order to download a song, play samples and pass songs to your friends."


This isn't really the same as the other bug, then. Same back-end software, it looks like, but some different issues to evangelise.
Status: RESOLVED → REOPENED
OS: Windows XP → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
I'm not seeing a specific bug for the Web site itself.

In http://www.songtouch.com/faq, in a funny reverted course of events. Now the site seems to target WebKit instead of Windows.

> What platforms or formats are currently available and what’s coming soon?
> 
> Alfred Play-Along powered by Jammit is currently available for the iPad,
>  iPhone, iPod Touch, and Mac desktop. Coming soon for Windows. 

If they need to be contacted in the future.
http://jammit.uservoice.com/knowledgebase

Though there is a need for analysis to know what is the issue we want to contact them about.
Assignee: english-us → nobody
Status: REOPENED → NEW
Component: English US → Desktop
Whiteboard: [country-us] [needanalysis]
http://musicstore.songtouch.com/mac.htm and the original http://www.songtouch.com/welcom.aspx don't exist anymore. Let's close this as INVALID.
Status: NEW → RESOLVED
Closed: 13 years ago6 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.