Crash when "Send Later" or "Save Message" is chosen [@ DocumentViewerImpl::LoadComplete fb45c7a1]

VERIFIED FIXED

Status

()

Core
Document Navigation
--
critical
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Tomcat, Assigned: Brian Ryner (not reading))

Tracking

({crash, regression})

Trunk
x86
All
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050616 Mnenhy/0.7.2.10002
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050616 Mnenhy/0.7.2.10002

Suite crashs when you compose a Message and choose "Send Later"
Regession between 2005061507 and 2005061603

Reproducible: Always

Steps to Reproduce:
1. Compose a Messsage 
2. Select "Send Later"
3.

Actual Results:  
Crash when Saving a Message or Send Later
(Reporter)

Comment 1

13 years ago
This happens also when Saving a Newsgroup Message and also a normal Email

Talkback ID TB6732865Y

Stack Signature	 DocumentViewerImpl::LoadComplete fb45c7a1
Product ID	MozillaTrunk
Build ID	2005061605
Trigger Time	2005-06-16 12:01:33.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	gklayout.dll + (0001abb9)
URL visited	
User Comments	Try to save Message (Newsgroup) with Save-Button, but File=Save
and Ctrl-S crash Mozilla too. :)
Since Last Crash	288 sec
Total Uptime	288 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp,
line 1029
Stack Trace 	
DocumentViewerImpl::LoadComplete 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp,
line 1029]
nsDocShell::EndPageLoad 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 4634]
nsWebShell::EndPageLoad 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/docshell/base/nsWebShell.cpp,
line 667]
nsDocShell::OnStateChange 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/docshell/base/nsDocShell.cpp,
line 4560]
nsDocLoader::FireOnStateChange 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 1199]
nsDocLoader::doStopDocumentLoad 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 833]
nsDocLoader::OnStopRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/uriloader/base/nsDocLoader.cpp,
line 654]
nsLoadGroup::RemoveRequest 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/netwerk/base/src/nsLoadGroup.cpp,
line 732]
nsCachedChromeChannel::HandleStopLoadEvent 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/rdf/chrome/src/nsChromeProtocolHandler.cpp,
line 487]
ntdll.dll + 0x30c24 (0x778b0c24)

Updated

13 years ago
Keywords: regression

Comment 2

13 years ago
Bonsai link:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-06-15+05%3A00%3A00&maxdate=2005-06-16+04%3A00%3A00&cvsroot=%2Fcvsroot
Keywords: crash
(Reporter)

Updated

13 years ago
Component: MailNews: Main Mail Window → Embedding: Docshell
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk
(Reporter)

Updated

13 years ago
Assignee: mail → adamlock
QA Contact: adamlock

Comment 3

13 years ago
On Linux. On my machine as quick as you hit send it crashes Mozilla. Was fine to
changes made on build 2005061602. 
Summary: Crash when "Send Later" or "Save Message" is choosen [@ DocumentViewerImpl::LoadComplete fb45c7a1] → Crash when "Send Later" or "Save Message" is chosen [@ DocumentViewerImpl::LoadComplete fb45c7a1]

Comment 4

13 years ago
this is almost certainly bug 292971
Assignee: adamlock → bryner
Depends on: 292971
OS: Windows 2000 → All

Comment 5

13 years ago
looks like bug 298022
(Reporter)

Comment 6

13 years ago
It seems that this is fixed with the Checkin from Bug 298022

Build 2005061810 is now working fine. Resolving this Bugreport as fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050628 on Windows XP Seamonkey trunk.
Status: RESOLVED → VERIFIED
Crash Signature: [@ DocumentViewerImpl::LoadComplete fb45c7a1]
You need to log in before you can comment on or make changes to this bug.