Closed Bug 297950 Opened 15 years ago Closed 15 years ago

Dynamic pseudo-classes doesn't work for class names with tag-wildcards in CSS

Categories

(Firefox Build System :: General, defect)

1.0 Branch
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 197686

People

(Reporter: xcf7e6fc842b1e62f, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Selectors such as ".className:hover { ... }" doesn't appear to work, but "tagName.className:hover { ... }" 
does work.

Reproducible: Always

Steps to Reproduce:
Consider the CSS:
.foo:hover { color: red; }
span.bar:hover { color: red; }

combined with HTML:
<span class="foo">foo</span>
<span class="bar">bar</span>
Actual Results:  
No result when hovering over "foo", hovering over "bar" changes it's color to red.

Expected Results:  
If my reading of the standard is correct (which it may very well not be), both "foo" and "bar" should change 
to red when hovering.

Safari, and probably other KHTML-browsers, renders the result described in "Expected Results".
Attached file testcase
I can confirm this, through the testcase

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050615
Firefox/1.0+ ID:2005061516
cc'ing and requesting block for 1.8b3.
Flags: blocking1.8b3?
Status: UNCONFIRMED → NEW
Component: General → Style System (CSS)
Ever confirmed: true
Product: Firefox → Core
Version: unspecified → Trunk
This is a duplicate of bug 96984, see bug 96984, comment 22.

*** This bug has been marked as a duplicate of 96984 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 197686 ***
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Flags: blocking1.8b3?
Status: RESOLVED → VERIFIED
Component: Style System (CSS) → Build Config
Product: Core → Firefox
Version: Trunk → 1.0 Branch
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.