Closed Bug 298011 Opened 15 years ago Closed 14 years ago

Last table-cell is too narrow

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Swatinem, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050607 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050607 Firefox/1.0+

I have a div with display: table.
Inside the div there are a few a's with display: table-cell. The Last one is
rendered too narrow.

Reproducible: Always

Steps to Reproduce:
Attached file Testcase
Compare this testcase with for example Operas rendering and you see what i
mean.
Keywords: testcase
Attached file testcase2
I've replace the letters with only the letter I, so you get the same
(intrinsic?) width in every table cell.
When the body margin is removed, the bug goes away.
When the body margin is made 50px, the bug gets (a bit) worse.
The bug can also be seen in Mozilla1.02.
Status: UNCONFIRMED → NEW
Ever confirmed: true
try resizing the window then you can see the cells flipping around.
Ah, ok, so the body margin has got nothing to do with this.
>The Last one is rendered too narrow.
does that violate any spec?
(In reply to comment #6)
> >The Last one is rendered too narrow.
> does that violate any spec?
I don't know, afaik, large areas of css table display is undefined. But wouldn't
it be nice if Mozilla is compatible with Opera and IE here?
I can't reproduce the bug with a recent build
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061209 Minefield/3.0a1
Looks like it got fixed in the meanwhile (by reflow branch perhaps?)

However I notice another bug:
Open the 2nd testcase, set the body margin to 0 and start resizing the page. You should see the horizontal scrollbar appearing, disappearing and reappearing while you resize the window. But that looks like a different bug. Should I open a new bug for that?
The original bug and the one I described in comment #8 seem to be fixed.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
I can see the bug with a 2006-12-07 build, but not anymore with a 2006-12-08 build, so I think this was fixed by the reflow branch landing.
Status: RESOLVED → REOPENED
Flags: in-testsuite?
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.