Urlbar drop-down when typing URL sometimes stops working

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
major
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Since a few days (maybe two weeks?) i sometimes get the problem that when i type
in a new URL (or the beginning of a URL) the drop-down appears, that's fine so
far. But then when i press the down array key, the first (2nd, 3rd, etc.) won't
be selected, instead in JS Console this error appears:
Error: this.activeChild has no properties
Source File: chrome://navigator/content/urlbarBindings.xml
Line: 373

Neil also wondered how this code ever worked since mSelectedIndex only defines a
setter, but no getter.
(Reporter)

Comment 1

13 years ago
Opening a new tab (or using a old one) doesn't work, in a new window everything
works again.

Updated

13 years ago
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
I did not see this bug occour for a long time now, i guess it's wfm.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.