User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+ Build Identifier: trunk "endDate" is a poor name for the recur-until date. It is easy to confuse with the end date of the event. It is also different from event endDate in that it is inclusive rather than exclusive. RFC2445 uses "UNTIL" rather than enddate. Suggest renaming to use the same terminology: calIRecurrenceRule.idl - attribute calIDateTime endDate; + attribute calIDateTime untilDate; Reproducible: Always Steps to Reproduce:
Created attachment 397941 [details] [diff] [review] Fix - v1 Makes sense, this patch should fix it.
Comment on attachment 397941 [details] [diff] [review] Fix - v1 Looks good to me. r=markus
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/7045fb8f5e2d> -> FIXED