Crash on Firefox loading, maybe after an extension installation [@ DocumentViewerImpl::InitPresentationStuff 8f5e9d70]

RESOLVED WORKSFORME

Status

()

Toolkit
Startup and Profile System
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Rotem Liss, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050617 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050617 Firefox/1.0.4

After Firefox 1.0.4 installation, Firefox started to crash after almost any
extension installation and restarting (it even didn't install the extensions!).
I didn't report all the crashes (but they were many crashes), but only 2:
6775358 6775934.

By the way, look at http://tinyurl.com/7thno : there are many users who also
crashed, but it is does not happen to anyone, and not for the same reason.

The crash is done only in one profile, but is done ALSO IN SAFE MODE.

By the way, I've tried to uninstall my current nightly build and install
another, but it crashed on startup from the same reason (it is the first one -
6775358). No, I didn't install any extensions then.

When installing extensions after deleting the "chrome" and "extensions" folders
(and also XUL.mfl and compatibility.ini, and chrome.rdf from the program folder
chrome), it doesn't crash - but after a while, it starts crashing after a
restart which is after an extension installation.

Also, I've formatted the computer (not from the same reason), reinstalled
Firefox (the only things I moved from the first profile to the another one are
"bookmarks.html" and "history.dat"), but the problem returned.

IT IS NOT FOR A SPECIFIC EXTENSION BUG - IT HAPPENS ALSO IN SAFE MODE.

Reproducible: Sometimes

Steps to Reproduce:
1. Create a new profile, install some extensions.
2. Go to it after a while, install more.
3. Try to load.
Actual Results:  
Firefox crashes (also in safe mode).

Expected Results:  
Firefox loads normally.

Incident ID: 6775358
Stack Signature	DocumentViewerImpl::InitPresentationStuff 8f5e9d70
Product ID	Firefox10
Build ID	2005061704
Trigger Time	2005-06-18 01:39:01.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (001915aa)
URL visited	Just Started
User Comments	
Since Last Crash	0 sec
Total Uptime	1 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 651
Stack Trace 	
DocumentViewerImpl::InitPresentationStuff 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 651]
DocumentViewerImpl::InitInternal 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 876]
DocumentViewerImpl::Init 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 639]
nsDocShell::Embed 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 4418]
nsDocShell::CreateAboutBlankContentViewer 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 4755]
nsDocShell::EnsureContentViewer 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 4661]
nsWebShell::GetInterface 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsWebShell.cpp,
line 318]
nsGetInterface::operator() 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp,
line 53]
nsCOMPtr_base::assign_from_helper 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 114]
GlobalWindowImpl::GetDocument 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 1108]
nsWindowWatcher::URIfromURL 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 1153]
nsWindowWatcher::OpenWindowJS 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 509]
nsWindowWatcher::OpenWindow 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 469]
XPTC_InvokeByIndex 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2034]
XPC_WN_CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1781]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 955]
js_Interpret 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 2999]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 972]
nsXPCWrappedJSClass::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1339]
nsXPCWrappedJS::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
SharedStub 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 147]
xre_main 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/toolkit/xre/nsAppRunner.cpp,
line 1854]
main 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)

Incident ID: 6775934
Stack Signature	DocumentViewerImpl::InitPresentationStuff 8f5e9d70
Product ID	Firefox10
Build ID	2005061704
Trigger Time	2005-06-18 02:24:42.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	FIREFOX.EXE + (001915aa)
URL visited	Just Started
User Comments	Installed some extensions.
Since Last Crash	1888 sec
Total Uptime	2047 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 651
Stack Trace 	
DocumentViewerImpl::InitPresentationStuff 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 651]
DocumentViewerImpl::InitInternal 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 876]
DocumentViewerImpl::Init 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/content/base/src/nsDocumentViewer.cpp,
line 639]
nsDocShell::Embed 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 4418]
nsDocShell::CreateAboutBlankContentViewer 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 4755]
nsDocShell::EnsureContentViewer 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsDocShell.cpp,
line 4661]
nsWebShell::GetInterface 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/docshell/base/nsWebShell.cpp,
line 318]
nsGetInterface::operator() 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp,
line 53]
nsCOMPtr_base::assign_from_helper 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 114]
GlobalWindowImpl::GetDocument 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 1108]
nsWindowWatcher::URIfromURL 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 1153]
nsWindowWatcher::OpenWindowJS 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 509]
nsWindowWatcher::OpenWindow 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 469]
XPTC_InvokeByIndex 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2034]
XPC_WN_CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1781]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 955]
js_Interpret 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 2999]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 972]
nsXPCWrappedJSClass::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1339]
nsXPCWrappedJS::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
SharedStub 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 147]
xre_main 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/toolkit/xre/nsAppRunner.cpp,
line 1854]
main 
[c:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)
(Reporter)

Updated

13 years ago
Keywords: crash

Comment 1

13 years ago
Reporter, can you please test the extensions that you are installing.  Can you
try and find out which extension is causing the issue.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Reporter, can you please test the extensions that you are installing.  Can you
> try and find out which extension is causing the issue.

I've installed all my old extensions in a new profile (and copied all the files
are not XUL.mfl, compatibility.ini and chrome and extensions from the old
profile to the new profile), and it still doesn't crash. Anyway, it crashes in a
full copy of the profile (after an extension installation and then restart of
the program).

It is not a specific extension.

I've fixed my profile full copy (deleted XUL.mfl, compatibility.ini and chrome
and extensions folders), and have done restart OF THE COMPUTER. Now I will try
to install an extension in this fixed profile... I think the fixed profile will
crash, again, and it will prove that it is another file, and happens only after
restart.
(In reply to comment #2)
> I've fixed my profile full copy (deleted XUL.mfl, compatibility.ini and chrome
> and extensions folders), and have done restart OF THE COMPUTER. Now I will try
> to install an extension in this fixed profile... I think the fixed profile will
> crash, again, and it will prove that it is another file, and happens only after
> restart.

When you try to install an extension please make a diff before the installation
and before the restart. Then check which files were modified. Perhaps try to
find out which of the changes causes the crash. Therefor you can exchange this
files one by one with the first version. I think we will come a little bit
closer to the problem. For myself I can't reproduce this bug.
(Reporter)

Comment 4

13 years ago
I've just started to try reproducing the bug, and noticed deleting the "temp"
folder does not help. I will now try to mark the extension "toBeInstalled" as a
comment in extensions.rdf...
(Reporter)

Comment 5

13 years ago
All of them didn't help: nothing of them, one of them (deleting
"extensions/temp" folder in the profile, and marking the extension
"toBeInstalled" as a comment in "extensions/extensions.rdf"), both of them
didn't fix the problem. I will try something else in a couple of days...
Reporter, please follow the instructions I made and perhaps use a current
nightly build or Deer Park Alpha 1 of Firefox.  
(Reporter)

Comment 7

13 years ago
The only file which changing it prevents Mozilla from crash, is
compatibility.ini. (I've changed it, and Mozilla didn't crash.) The change was,
from:

[Compatibility]
Build ID=2005061704
Components List Changed=1

to:

[Compatibility]
Build ID=2005061704
Components List Changed=0

But I'm not sure if it helps. By the way, changing to:

[Compatibility]
Build ID=2005061704
Components List Changed=2

also prevents it from crash.

Changing all the others - chrome/chrome.rdf, extensions/extensions.rdf,
extensions/temp - didn't change Mozilla's behavior: still crashed.
(Reporter)

Comment 8

13 years ago
Replacing "extensions", "chrome" and "forecastfox" (an extension installed)
folders with the previous ones didn't prevent Firefox from crashing. Only
replacing "compatibility.ini" with the previous helped.

By the way, preventing from crash don't say it actually *installed* the extension.
(In reply to comment #7)
> The only file which changing it prevents Mozilla from crash, is
> compatibility.ini. (I've changed it, and Mozilla didn't crash.) The change
> was, from:
> Components List Changed=1
>
> to:
> 
> Components List Changed=0

Rotem, please try the Deer Park Alpha 1 release or a current nightly build.
Hopefully the crash shouldn't appear with these builds due to massive code
changes between Aviary and Deer Park. If it still appear send a talkback report
and tell us the id. Thank you.

Comment 10

13 years ago
This will be closed if we do not see confirmation with the latest build.
(In reply to comment #10)
> This will be closed if we do not see confirmation with the latest build.

Why? Please do not close bugs that contain a valid stack without a very good reason.

Comment 12

13 years ago
Because using old builds doesn't help.  Please can you try Deer Park Alpha 2.
(Reporter)

Comment 13

13 years ago
Probably fixed (I've never reproduced it again in Firefox 1.5), marking Resolved Worksframe. I will reopen it if it will return.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

7 years ago
Crash Signature: [@ DocumentViewerImpl::InitPresentationStuff 8f5e9d70]
You need to log in before you can comment on or make changes to this bug.