"Report Broken Website" should be followed by ellipsis

RESOLVED FIXED

Status

Other Applications
Reporter
--
trivial
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Asher, Assigned: raccettura)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.21 KB, patch
Benjamin Smedberg
: review+
Benjamin Smedberg
: approval1.8b4+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050619 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050619 Firefox/1.0+

On the Help menu, "Report Broken Website" should be renamed "Report Broken
Website..." for HIG consistency (also to be consistent with "Check for Updates".

Also, the R keyboard shortcut conflicts with Release Notes.

Reproducible: Always

Updated

13 years ago
Assignee: nobody → robert
Component: Menus → Reporter
Product: Firefox → Other Applications
QA Contact: menus → xul-client
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

13 years ago
Attachment #186920 - Flags: review?(mconnor)
*** Bug 299392 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
Comment on attachment 186920 [details] [diff] [review]
Patch

I think that we should do this by adding the ellipsis directly to the XUL,
instead of changing the localized entity, to avoid late-l10n problems (AFAIK
nobody needs to localize the ellipsis).
Attachment #186920 - Flags: review?(mconnor) → review-

Comment 4

13 years ago
Would the Hebrew localization (a right to left language) not want the elipsis on
the left side of the text? 
Zach, it should be at the (direction-)logical end, so setting it in the XUL is fine.
(Assignee)

Comment 6

13 years ago
Created attachment 190409 [details] [diff] [review]
Patch directly to xul
(Assignee)

Updated

13 years ago
Attachment #186920 - Attachment is obsolete: true

Updated

13 years ago
Attachment #190409 - Flags: review+
Attachment #190409 - Flags: approval1.8b4+
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

13 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 8

13 years ago
Will this be made consistent with the rest of the app once the trunk reopens?
(In reply to comment #8)
> Will this be made consistent with the rest of the app once the trunk reopens?

Bug 317702 filed on removing the hard coded ellipsis.
Depends on: 317702
You need to log in before you can comment on or make changes to this bug.