Firefox does not sanitize history or cookies if it is closed during a shutdown or logout

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: ramainSF, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050524 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050524 Firefox/1.0+

Deer park does not perfrom the sanitize settings if it is closed during a logout
or shutdown command.  It works if the program is quit normally.

Reproducible: Always

Steps to Reproduce:
1) Check sanitize history, cookies & cache when closing firefox.
2) Open firefox and browse the web
3) Hide Firefox
4) Logout of mac session using the "Log Out" menu in the apple menu
5) Login to account
6) Open Firefox.  The history from the previous session is still available.


Actual Results:  
History was not cleared.  Instead of logging out of the mac sesion, if you just
quit firefox and then re-open it, the session has been cleared.

Expected Results:  
Use sanitize if it is closed from either the quit command or if it gets a logout
command.

Comment 1

13 years ago
This is normal, since shutdown hooks which invoke the sanitization routines
can't run if Firefox exits abruptly.
Patches for bug #284086 *may* fix this issue (I cannot build and test on Mac OS
X), but they do work-around, since they sanitize on restart if shutdown
sanitization was missing dued to premature exit.
Status: UNCONFIRMED → NEW
Depends on: 284086
Ever confirmed: true
Summary: Firefox does not sanitize history or cookies if it is closed during a shutdown or logout → Firefox does not sanitize history or cookies if it is closed during a shutdown or logout

Comment 2

11 years ago
Giorgio in comment #1
> This is normal, since shutdown hooks which invoke the sanitization routines
> can't run if Firefox exits abruptly.

so what should be disposition of this bug?
does patch in bug 314755 help?  dupe?

Comment 3

11 years ago
I cannot reproduce in a current branch build, clean profile on Mac OS X 10.4.8.
If I try to restart the OS and I've got the "Ask me before clearing private data" option enabled, I'm normally asked and data gets cleared.
Data seems to be cleared also in unattended mode, but I'd like some more independent confirmation and possibly a hint to tell if this is a WORKSFORME or a FIXED.

Comment 4

11 years ago
WFM is appropriate because given the passage of time, unless you test a build from just after bug 284086 we don't know exactly what fixed it. see https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution for more info
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.