Context menu contains both "Mark -> As Read" and "Mark -> Thread As Read"

RESOLVED INVALID

Status

--
trivial
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: 32768, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050619 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050619 Firefox/1.0+

In the folder view, the context menu contains both "Mark -> As Read" and "Mark
-> Thread As Read".  This is the case whether the current thread is marked as
read or not.  It is also the case when multiple threads are selected.

The behaviour of "Mark -> As Read" changes according to whether the selected
thread(s) is already marked as read, whereas the behaviour of "Mark -> Thread As
Read" does not.  Therefore, "Mark -> Thread As Read" is redundant.

Reproducible: Always

Steps to Reproduce:
1. Select one or more threads
2. View context menu
Actual Results:  
Context menu contains both "Mark -> As Read" and "Mark -> Thread As Read"

Expected Results:  
Context menu contains only "Mark -> As Read"

Comment 1

14 years ago
For the purposes of popping up a context menu, it is probably too compute-
intensive an operation to check all messages in the thread to decide whether to 
disable or hide the Mark Thread Read item.

xref bug 233182.
Severity: normal → trivial
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 2

14 years ago
The problem doesn't involve detecting if threads are read or not.

The problem is that the same option is always shown twice in the context menu -
'Mark -> Thread As Read' needs to be removed as its behaviour is always
duplicated by 'Mark -> As Read'.

In other words 'Mark -> Thread As Read' is superfluous and should be removed.

Comment 3

14 years ago
(In reply to comment #2)
> In other words 'Mark -> Thread As Read' is superfluous and should be removed.

If that's what you think, you don't understand the situation at all.

Mark Thread as Read clearly has behavior different from Mark as Read; if you're 
not using threaded views, you won't see the difference, but that's not a problem 
with the program.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.