Remove "Changed" from email subject line

RESOLVED FIXED in Bugzilla 2.12

Status

()

Bugzilla
Bugzilla-General
P3
normal
RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: Richard Zach, Assigned: justdave)

Tracking

unspecified
Bugzilla 2.12

Details

(Whiteboard: 2.12)

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
Can you remove the "Changed -" from the subject line, so that it is of the form
"[Bug xxxx] Summary".  Would make it easier to recognize bugs from the subject
line, which is otherwise truncated in the thread display.
QA Contact: matty

Comment 1

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara

Comment 2

18 years ago
good suggestion, maybe for 2.12
Assignee: tara → cyeh
Whiteboard: 2.12

Comment 3

17 years ago
Created attachment 14547 [details] [diff] [review]
patch to fix...

Comment 4

17 years ago
Created attachment 14550 [details] [diff] [review]
slightly less hacky patch to fix...

Comment 5

17 years ago
checked into trunk with commentary
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
*** Bug 48741 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Sorry for the spam, but I needed to be able to query for all of these correctly.
Target Milestone: --- → Bugzilla 2.12

Comment 8

17 years ago
Yeppers.
Status: RESOLVED → VERIFIED

Comment 9

17 years ago
Reopening.

The subject is now "[Bug nn]  - subject" which means still four excess characters
(space, space, dash, space).  Attaching a new patch.  Also, the description in
defparams.pl wasn't correct any more - this patch fixes this, too.

Please make sure that when bugzilla.mozilla.org updates to this patch that the
parameter "changedmail" is also reset to the new default.  Thanks!
Status: VERIFIED → REOPENED
Keywords: patch, review
Resolution: FIXED → ---

Comment 10

17 years ago
Created attachment 27881 [details] [diff] [review]
new patch (diff -ubB)

Comment 11

17 years ago
Created attachment 27882 [details] [diff] [review]
new patch (diff -u, also removing spaces at line endings)
Assignee: cyeh → dave
Status: REOPENED → NEW
r= dave@intrec.com

except:  I think the [Bug xxxx] should still be first before the %neworchanged% 
in the default.  I'd bet that a LOT of people probably have mail filters that 
look for the subject beginning with "[Bug ".
Created attachment 28216 [details] [diff] [review]
New patch
Here's a new version of the patch, I swapped the order around again so that the 
"[Bug xxx]" is always first.  I also discovered that the previous patch posted 
here only patched the defparam for "changedmail" and only patched the 
substitution setup on the newemailtech (which uses "newchangedmail").  This patch 
also adds the change to defparams for "newchangedmail" and also the change to the 
substitution setup for oldemailtech.

Comment 15

17 years ago
The only thing I don't like about this latest patch is that if you don't go in
and change your parameters to the new default, new bugs of a subject line like
follows:
[Bug 35] New:  - Reorginize the Hilite Intranet

OTOH, I really don't see a way around that.  Guess that's just another thing to
put in the 2.12 release notes (are those in the works?).

r= jake@acutex.net

Comment 16

17 years ago
Latest patch is okay with me, too.  I must have missed the oldemailtech code
since I don't use it any more.

I thought putting the "New" in front would help to avoid confusing it as part
of the summary, but on the other hand it would mess up sorting the mailbox by
summary.  But then, maybe one day bug 31314 will be fixed and this won't matter
any more ...
Blocks: 53044
OS: Linux → All
Hardware: PC → All

Comment 17

17 years ago
r=cyeh
Checked in.  Heads up, Barnboy, this needs to be release-noted.

CVS checkin comments:

UPGRADE NOTES: when you install this update, you will need to change the subject 
line in your 'changedmail' and 'newchangedmail' params from the web by running 
editparams.cgi. The subject line needs to be changed from:
Subject: [Bug %bugid%] %neworchanged% - %summary%
to
Subject: [Bug %bugid%] %neworchanged%%summary%

Or whatever is appropriate for the subject you are using on your system. Note the 
removal of the " - " in the middle. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Updated

17 years ago
No longer blocks: 53044
Moving closed bugs to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified

Comment 20

13 years ago
when I report the bug, and will report a mail to someone.
If the bug report have Chinese character, when receive the mail,the Chinese 
character will confusion,how can I add mail encode on the report mail?
I think the default encode shoule "UTF-8".

If you resolve this, please send the resolve  method to my 
mail:gzhu@qilinsoft.com
(In reply to comment #20)
> If the bug report have Chinese character, when receive the mail,the Chinese 
> character will confusion,how can I add mail encode on the report mail?

That has nothing to do with this bug.  That's bug 126266.

Comment 22

13 years ago
(In reply to comment #21)
> That has nothing to do with this bug.  That's bug 126266.

How can I resolve that question?

Open CGI.pm and find the line
     $self->charset('');
and change to
     $self->charset('UTF-8');

can resolve it?
When I after save CGI.pm, then it will take effect?


QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.