Keyboard not working with MacOSX 10.4.1 (Tiger) - Java issue?

RESOLVED WORKSFORME

Status

()

--
blocker
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: andreas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; de-de) AppleWebKit/412 (KHTML, like Gecko) Safari/412
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050523 Firefox/1.0

After starting Deer Park the keyboard is no longer working in any way.
It is impossible to enter URLs into the location input field or use menu short cuts.
It just looks like the complete keyboard is blocked. This happens shortly after some request.

Reproducible: Always

Comment 1

13 years ago
Looks like there is a problem with your computer in a way.

I am using Tiger 10.4.1 and trunk builds - what would become DeerPark Alpha 2 -
and I cannot see any keyboard freezing.

Is this bug only happening with DeerPark Alpha 1 ?
(Reporter)

Comment 2

13 years ago
The error only occurs with DP. Any other application is working fine. But I am trying the trunk version now.

(Reporter)

Comment 3

13 years ago
Same problem with latest nightly build...it freezes.
(Reporter)

Comment 4

13 years ago
Same problem with latest nightly build...it freezes.

Comment 5

13 years ago
Does this depend on the keyboard layout?

Comment 6

13 years ago
Need more info.

Comment 7

13 years ago
I've seen this... not sure what causes the problem at all... Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050716 Firefox/1.0+
(PowerBook) & 10.4.2

I ran into this problem last night after running http://speed.try.wideopenwest.com/

Comment 8

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908
Firefox/1.4

This happens for me with 1.5 Beta 1 when visiting the same URL listed above
(http://speed.try.wideopenwest.com/). It only appears to affect the tab in which
that URL was loaded.

My guess is that it's some bug in the interaction with the Java plugin (the
speed test is a Java applet).

Updated

13 years ago
Summary: Keyboard not working with MacOSX 10.4.1 (Tiger) → Keyboard not working with MacOSX 10.4.1 (Tiger) - Java issue?
I'm able to reproduce this problem with copies of Firefox (or DeerPark) that
bundle the Java Embedding Plugin (such as Firefox 1.5 Beta 1).  The 2005-07-16
Firefox nightly didn't bundle the Java Embedding Plugin.  But you'll
experience the same problem if you've downloaded the JEP from
http://javaplugin.sourceforge.net/ and installed it to your /Library/Internet
Plug-Ins/ directory.

This problem only happens in Carbon-based browsers (like Firefox, SeaMonkey,
or the Mozilla Suite), not in Cocoa-based ones (like Camino).

And it only happens with a very small number of applets -- which is why I
hadn't noticed it before.  But, unfortunately, that small number does include
the speed test applet at http://speed.try.wideopenwest.com/.

There's a workaround -- click the mouse somewhere on your Mac's desktop, then
back again somewhere in the browser page containing the statistics on your DSL
connection.

I already have this fixed in my current version of the Java Embedding Plugin,
which I should be able to release in the next few days as version 0.9.4+a (a
so-called "nightly").

If your browser doesn't bundle an older version of the Java Embedding Plugin,
just download the new version (once it's available) and install it to your
/Library/Internet Plug-Ins/ directory, as per the JEP Readme.

If your browser does bundle an older version of the JEP, there will be two
possible solutions:

1) If Mozilla.org lands the new JEP on the trunk and 1.8 branches reasonably
   quickly, you'll just need to download a new nightly from after that
   happens.

2) Otherwise you'll need to download the new JEP from
   http://javaplugin.sourceforge.net/, install it to your /Library/Internet
   Plug-Ins/ directory, and then also remove the old JEP from the
   Contents/MacOS/plugins directory of your copy of Firefox.

Of these two alternatives, I much prefer #1, and I hope that's what I'll be
able to tell people to do.

Comment 10

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050912
Firefox/1.4

10.4.2 -- with apples latest java update thing (a week old or so)

When I use(ed) the wideopenwest applet to check my speeds the mouse always stays
in the pressed state... so if I move the mouse up (from the start button) I
start selecting text... I would think this is why the keyboard doesn't work...
is that a JEP issue?
> When I use(ed) the wideopenwest applet to check my speeds the mouse always
> stays in the pressed state... so if I move the mouse up (from the start
> button) I start selecting text... I would think this is why the keyboard
> doesn't work...  is that a JEP issue?

That issue is actually caused by an Apple bug (though the text-selection
behavior was triggered by recent changes in DeerPark/Firefox), and is
completely unrelated to this one.

See bug 306874.

(Following up comment #9)

The issue with http://speed.try.wideopenwest.com/ is fixed by version 0.9.4+a
of the Java Embedding Plugin, which was released a few days ago.  This version
of the JEP is bundled with new Mozilla.org browser nightlies as of 2005-09-27.

So the easiest way to resolve this problem is to download the latest nightly
of Firefox/DeerPark, Camino or SeaMonkey.

But if (for some reason) you don't want to do this, follow option 2) in
comment #9 above.

Comment 13

13 years ago
is this related in any way to bug 283050?
> is this related in any way to bug 283050?

No.  At least not the issue with http://speed.try.wideopenwest.com/.

And it looks like the comments at bug 283050 discuss a couple of different
problems, possibly unrelated to each other.

here, too, the original report seems unrelated to the problem with
http://speed.try.wideopenwest.com/ :-)

But only the report on http://speed.try.wideopenwest.com/ contained enough
information to be useful.

Comment 15

13 years ago
(In reply to comment #12)
> (Following up comment #9)
> 
> The issue with http://speed.try.wideopenwest.com/ is fixed by version 0.9.4+a
> of the Java Embedding Plugin, which was released a few days ago.  This version
> of the JEP is bundled with new Mozilla.org browser nightlies as of 2005-09-27.
> 

indeed i don't see this issue anymore. resolve bug?
> resolve bug?

Sounds like a good idea to me.

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.