Unable to open new browser window if download manager is only open window.

RESOLVED DUPLICATE of bug 239218

Status

()

--
minor
RESOLVED DUPLICATE of bug 239218
14 years ago
10 years ago

People

(Reporter: bardiche, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If the download manager is selected, then hitting Command-N will not bring up a
new window until the download manager is closed or a browser window is selected.

Most notable when all browser windows are closed and the download manager window
is left open. You can not open a new browser window until the download manager
is closed. Also note that you can not use any menu except the "Firefox" menu
until download manager is closed


Reproducible: Always

Steps to Reproduce:
0.Close ALL firefox browser windows.
1.Open a new browser window and go to a page where you can download something.
2.Download something.
3.Download manager should be visible.
4.Close the browser window opened in step 1.


Actual Results:  
1.Note that you may not open a new browser window until download manager is closed.
2.Also note that the file, edit, view, go, bookmakrs, tools, window, and help
menus are also unavailable.
3.Also note that if you do step 0-3,that you are still allowed to open annother
browser window if one is already open.

Conclusion: The sofware behaves differently when 
Case 1: (the download manager is open) AND (0 Browser Windows open)
Case 2: (the download manager is open) AND (>0 Browser Windows open)


Expected Results:  
The software should behave the same whether 0 or >0 browser windows are open in
conjunction with the download manager window being open.


Workaround:
To open a new browser window when only the download manager window is open,
close the download manager then open a new browser window.
Already fixed, will be in Firefox 1.1.

*** This bug has been marked as a duplicate of 239218 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.