Padding extend div size to width + padding

RESOLVED DUPLICATE of bug 50449

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 50449
13 years ago
13 years ago

People

(Reporter: Emmanuel Berre, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When adding x px of padding in a div with few caracters, the div width of the
div is extended to a new size. The new size is the sum of the padding and the
fixed width.

Reproducible: Always

Steps to Reproduce:
1. Define a css style such as this :
.bas 
{
	padding : 3px 5px 3px 5px;
	position: absolute;
	left: 0px;
	bottom: 0px;
	width: 100%;
	margin: 0px;
}

2. define a div in a page using this style.

Actual Results:  
The width of the div equals width + padding

Expected Results:  
The size of the div would have been fixed to the one specified in the css sheet.
Use of padding must provide white space in the inner part of the div, not adding
extra space.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 50449 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.