Control + arrow does not behave as expected

RESOLVED DUPLICATE of bug 289708

Status

()

Core
Editor
--
minor
RESOLVED DUPLICATE of bug 289708
13 years ago
13 years ago

People

(Reporter: Mattias, Assigned: Joe Francis)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: TB version 1.0+ (20050601)

When using control + right arrow, the movement between words is different than
when using the left arrow.  It appears that CRLF and punctuation characters are
not considered the end of a word when going to the right, but are when going to
the left.

Reproducible in both HTML and plain text format

Reproducible: Always

Steps to Reproduce:
1. Open a new email
2. Type "asdf"<enter>"asdf"<enter>"asdf"<enter> (without the quotation marks)
3. Place cursor at the beginning of the message
4. Press Ctrl+Right
5. Press Ctrl+Left
Actual Results:  
Step 4 moves cursor to the very end, and step 5 moves cursor to the left of the
last "asdf"

Expected Results:  
Step 4 moves cursor to the right of "asdf" on the first line, and step 5 moves
cursor back to its original location

Updated

13 years ago
Assignee: mscott → mozeditor
Component: Message Compose Window → Editor
Product: Thunderbird → Core
Version: unspecified → 1.0 Branch

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 289708 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.