allow bookmarks to be displayed in a sidebar (using a split view)

RESOLVED WONTFIX

Status

Camino Graveyard
Bookmarks
--
enhancement
RESOLVED WONTFIX
13 years ago
13 years ago

People

(Reporter: Ulrik Sverdrup, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)
Build Identifier: first officialfficial 0.9a1 alpha release

Camino should provide the option to display the bookmarks manager in a sidebar
using a split view. The sidebar booksmarks manager only has to complement the
full-window manager, but will provide the same get info inspector and editing
possibilities.

An example of this design is Firefox 1.0

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 186932 [details]
A firefox screenshot of the splitview bookmarks viewer/manager

Screenshot attached to show how the Firefox split view solution looks. Note
that the bookmarks sidebar is shown outside any tab context, with the sidebar
in one split view pane, and all the tabs in the other pane. This should make it
easier to  not exclude using a full-screen bookmarks manager at the same time.

Bookmark groups are displayed as folders at the top; this is how we can display
all the special collections we have too.

Comment 2

13 years ago
Didn't we kill the sidebar idea long ago?
Yes. This should be WONTFIXed. I'm not sure the sidebar ever made it into a bug,
just in chats in IRC.
That's one of the worst parts of the Fx UI; the *unmentionable* was better than
the Fx sidebar, and as we've said, the current BM handily beats the pants off of
that.
(Reporter)

Comment 5

13 years ago
It's not because it's a bad idea that we won't do it, as I understand it. 

We'll have to focus on one type of functionality for the bookmarks manager, and
I guess most will want a more powerful full-window bookmarks manager, rather
than a sidebar.

I don't think our old drawer would be an equivalent or better solution - it just
has the controls in the wrong place. A split view means you can adjust the width
of any of the panes with a control in the middle; to do that with a drawer, you
have to both resize the window and the drawer. And you know there are lots of
more issues with drawers...

Comment 6

13 years ago
WONTFIXING Sam.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.