Nightly build will not start after install.

VERIFIED DUPLICATE of bug 297725

Status

VERIFIED DUPLICATE of bug 297725
14 years ago
14 years ago

People

(Reporter: troy.miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

The build dated "21-Jun-2005 09:46   12M " from
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/ fails to
start after an install.  Using file monitor from sysinternals it appears that
mozilla can't find xpcom.dll.  The files is not found and mozilla just exits
without any messages.

4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\mozilla.org\Mozilla\xpcom.dll
FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\system32\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\system\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\xpcom.dll	FILE NOT FOUND	Options:
Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\mozilla.org\Mozilla\xpcom.dll
FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\mozilla.org\Mozilla\xpcom.dll
FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\system32\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\xpcom.dll	FILE NOT FOUND	Options:
Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\System32\Wbem\xpcom.dll	FILE NOT
FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\ATI Technologies\ATI Control
Panel\xpcom.dll	FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program
Files\Embarcadero\Describe\Perl5\xpcom.dll	FILE NOT FOUND	Options: Open 
Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program
Files\Embarcadero\Describe\Perl5\lib\auto\gdperl\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program
Files\Embarcadero\Describe\bin\xpcom.dll	FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\ActivCard\ActivCard
Gold\resources\xpcom.dll	FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\j2sdk1.4.2_07\bin\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	CLOSE	C:\Program Files\mozilla.org\Mozilla	SUCCESS		

The directory C:\mozilla.org\GRE\1.8b2_2005062105 is present, but it doesn't
attempt to load from there as seen in the above output.

With 1.7.8 installed it is loaded from:

4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\mozilla.org\Mozilla\xpcom.dll
FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\system32\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\system\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\xpcom.dll	FILE NOT FOUND	Options:
Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\mozilla.org\Mozilla\xpcom.dll
FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\mozilla.org\Mozilla\xpcom.dll
FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\system32\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\xpcom.dll	FILE NOT FOUND	Options:
Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\WINDOWS\System32\Wbem\xpcom.dll	FILE NOT
FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\ATI Technologies\ATI Control
Panel\xpcom.dll	FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program
Files\Embarcadero\Describe\Perl5\xpcom.dll	FILE NOT FOUND	Options: Open 
Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program
Files\Embarcadero\Describe\Perl5\lib\auto\gdperl\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program
Files\Embarcadero\Describe\bin\xpcom.dll	FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\Program Files\ActivCard\ActivCard
Gold\resources\xpcom.dll	FILE NOT FOUND	Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	OPEN	C:\j2sdk1.4.2_07\bin\xpcom.dll	FILE NOT FOUND
Options: Open  Access: All	
4:11:10 PM	mozilla.exe:2832	CLOSE	C:\Program Files\mozilla.org\Mozilla	SUCCESS		



Reproducible: Always

Steps to Reproduce:
1. Install nightly build
2. Start mozilla


Actual Results:  
mozilla exited without any messages or screen output.

Expected Results:  
Started the browser.
(Reporter)

Comment 1

14 years ago
Some how the second cut-n-paste is wrong, duplicate of the first, with 1.7.8
installed the file is found like this:

4:07:52 PM	mozilla.exe:1488	DIRECTORY	C:\Program Files\mozilla.org\Mozilla\	NO
SUCH FILE	FileBothDirectoryInformation: xpcom.dll	
4:07:52 PM	mozilla.exe:1488	CLOSE	C:\Program Files\mozilla.org\Mozilla\	SUCCESS		
4:07:52 PM	mozilla.exe:1488	OPEN	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Options: Open  Access: All	
4:07:52 PM	mozilla.exe:1488	QUERY INFORMATION	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Attributes: A	
4:07:52 PM	mozilla.exe:1488	CLOSE	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS		
4:07:52 PM	mozilla.exe:1488	OPEN	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Options: Open 
Access: Execute	
4:07:52 PM	mozilla.exe:1488	QUERY INFORMATION	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Length: 415568	
4:07:52 PM	mozilla.exe:1488	CLOSE	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS		
4:07:52 PM	mozilla.exe:1488	OPEN	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Options: Open  Access: All	
4:07:52 PM	mozilla.exe:1488	QUERY INFORMATION	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Attributes: A	
4:07:52 PM	mozilla.exe:1488	CLOSE	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS		
4:07:52 PM	mozilla.exe:1488	OPEN	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.8_2005051112\xpcom.dll	SUCCESS	Options: Open  Access: All	

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 297725 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.