Support disk space verification in Mac/Unix .xpis

VERIFIED FIXED in M18

Status

SeaMonkey
Installer
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Samir Gehani, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3+])

(Assignee)

Description

19 years ago
Implement a aily upadted key like $Version$ indicating space required for the 
component being installed (say $SpaceRequired$).  Also, the install.js 
templates need to be updated to perform disk space verification before 
installing.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
OS: Windows NT → Mac System 8.5
Hardware: PC → Macintosh
Target Milestone: M15
(Assignee)

Updated

19 years ago
Target Milestone: M15 → M16
(Assignee)

Updated

19 years ago
Target Milestone: M16 → M18

Comment 1

19 years ago
we need to do diskspace checking before install.
Keywords: nsbeta2
Target Milestone: M18 → M17

Comment 2

19 years ago
*** Bug 32516 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
Adding myself to Cc.

Comment 4

19 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+] → [nsbeta2+] sgehani's fix ETA: 07/18
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+] sgehani's fix ETA: 07/18 → [nsbeta2+] sgehani's fix ETA: 07/24
This fix is hanging too far off the end, asking that this be chopped for 
nsbeta2.  The Mac is OK without this fix because the install wizard itself does 
some rudimentary space checking, though it may hurt the Netcenter SmartUpdate 
site for some people. Try again in nsbeta3
Keywords: nsbeta3
Whiteboard: [nsbeta2+] sgehani's fix ETA: 07/24

Comment 6

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [nsbeta2-]

Updated

18 years ago
Blocks: 46008
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3+]
(Assignee)

Comment 7

18 years ago
JJ will be adding $SpaceRequired$ parsing into the Mac build scripts that 
generate the .jsts next week sometime.  Once that is online, we merely need to 
modify the .jsts to check for diskspace.  

The Unix equivalent will be handled in deliver.pl.

Comment 8

18 years ago
mac done. you can edit the .jst files anytime and the Mac automation will pick it 
up.
Note that the size is currently inserted in Kbytes.
(Assignee)

Comment 9

18 years ago
Thanks JJ!
(Assignee)

Updated

18 years ago
Target Milestone: M17 → M18
(Assignee)

Comment 10

18 years ago
Fixes checked in for {moz,ns} x {mac,linux} .jst files.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
On a nearly full disk on the Mac, I am able to go through installation process- 
with some oddities, but no warnings. 
After 'Installing XPCOM'- I see processing file 14 of 14 for a very long time 
while 'Installing Navigator' and 'Installing Mail/News' is displayed.  I do not 
see the usual processing or installing of files 1-24xx for Navigator. It 
installs Instant Messenger- but bottom line is no launch, no executable files, 
no icon

With this fix, I expected to see 'disk space full' warning- is that correct?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

18 years ago
No, with this fix, if you update from teh browser (like using update.html) and 
you don't have enough space you should see INSUFFICIENT_DISK_SPACE (rather it's 
numeric error code equivalent) logged in the install log.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
Got it, verified using update.html - received error -235 INSUFFICIENT DISK SPACE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: agracebush → general
You need to log in before you can comment on or make changes to this bug.