no cursor input in a div when an other div in page have an overflow css-style

RESOLVED DUPLICATE of bug 167801

Status

()

defect
RESOLVED DUPLICATE of bug 167801
14 years ago
14 years ago

People

(Reporter: martinm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Crazy Browser 2.0.0 Beta 1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

<html>
<!--  click in the input field: the cursor won't appear 
  --  remove any of the 2 div or the overflow:auto style statement
  --  and it will work
  --  bug appears in 
  --   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 
Firefox/1.0.4
  -->
<body>
 
<div ' 
style='position:absolute;left:175px;top:49px;width:625px;height:426px;border: 
1px solid black;overflow:auto'>
</div>	
 
<div 
style='position:absolute;left:200px;top:150px;width:200px;height:50px;border: 
1px solid black;'>
  <form action="null.html" name='myform' method="POST">
  <input name='test' value='tsoin'>
  </form>        
</div>
 
</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. save code in datails fields as an html field
2. open it
3. clic in the input field


Actual Results:  
no cursor in the input field

Expected Results:  
cursor should appear

remove one of the div or the "overflow" statement and it will work correctly.

no work around found.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 223239 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Reporter

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Reporter

Comment 2

14 years ago
still now fixed in 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 
Firefox/1.0.6 

Comment 3

14 years ago
No, this is still not fixed using a trunk build. But this has already been
reported. Its a duplicate. 

Also, when it comes to testing, 1.0.6 uses the 1.7 gecko engine that is over one
year old. Test with trunk builds to test. But as said above, this is not fixed.

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.