trivial underquoted m4 macro fix

RESOLVED FIXED in 4.7

Status

defect
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: pw-fb, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.8b2) Gecko/20050620 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.8b2) Gecko/20050620 Firefox/1.0+

nspr.m4 may get installed in the system's aclocal directory, so no matter what
autotools versions mozilla is using, the user may still receive warnings about
underquoted macro names from a recent autoconf. (At the moment, these are just
warnings, but future versions of autoconf may be multi-pass, in other words, the
macro would be re-expanded on a second pass generating mess.)

The patch (to follow) is a trivial no brainer, so it should be easy to apply!

Reproducible: Always

Comment 2

14 years ago
Chris, could you review this bug report?  Thanks.
Assignee: wtchang → cls
Assignee

Updated

14 years ago
Attachment #187022 - Flags: review+

Comment 3

13 years ago
This mistake was reported by an Ubuntu user in our bug system, at
 https://launchpad.net/distros/ubuntu/+source/firefox/+bug/36659

I grepped the firefox 1.5.0.1 source tree for AC_DEFUN and fixed all of the instances that that found - there were twenty.

Comment 4

13 years ago
Comment on attachment 218036 [details] [diff] [review]
patch to fix some more AC_DEFUN instances

Ben, if m4 macros are not your area, please ask cls
to review this patch.  Thanks.
Attachment #218036 - Flags: review?(benjamin)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

13 years ago
Comment on attachment 187022 [details] [diff] [review]
as mentioned in original report

I checked in this nspr.m4 patch on the NSPR trunk (NSPR 4.7)
and NSPRPUB_PRE_4_2_CLIENT_BRANCH (Mozilla 1.9 alpha).
Assignee

Updated

13 years ago
Attachment #218036 - Flags: review?(benjamin) → review+
Assignee

Comment 7

13 years ago
Sorry, Ian. I gave improper attribution in the checkin comment.
Any chance this could go into the 1.8 branch?  It seems very low risk.

Updated

11 years ago
Duplicate of this bug: 375285
You need to log in before you can comment on or make changes to this bug.