Colour (color) for unvisited links is not in the palette

RESOLVED DUPLICATE of bug 42894

Status

()

Firefox
Preferences
--
minor
RESOLVED DUPLICATE of bug 42894
13 years ago
a year ago

People

(Reporter: Faraaz Damji, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

The colour for unvisited links is not in the palette, making it impossible to
set the colour for visited links to be the same as visited links without going
to about:config.

Also, if a user changes the colour for unvisited links, they will not be able to
change it back without manually resetting the value in about:config

Reproducible: Always

Steps to Reproduce:
1. Tools->Options->General->Fonts & colors
1.5 (optional) If you click on any color on that screen except for the unvisited
link color, you'll notice the white cursor around it on the color.  The
unvisited link shows no such white box.  While this may seem like the cursor's
just missing, it's because the colour actually isn't there

2. Try to change the color for visited links to the default color of unvisited
links.  There is one blue that looks similar, but it is actually different.
3. With some lower quality monitors, the two blues look the same.  If all the
links look the same in the screenshot (see attached URL), then you can confirm
that this bug exists by going to about:config and comparing the values for
browser.anchor_color with browser.visited_color.  If the colours are actually
the same, then the values should also be the same.
Actual Results:  
I could not change the visited link color so that it is the same as the
unvisited link color.  The closest colour on the palette is visibly lighter.

Expected Results:  
All the default colors should be on the palette.

This would allow users to revert to the defaults without going to about:config,
as well as allowing users to set the visited link color to be the same as the
unvisited link color.  This can all be done in about:config, but that's annoying
and shouldn't happen.

The colour that is not on the palette is #0000EE.  The colour that is somewhat
close to the default unvisited link color is #3333FF.

The screenshot shows the two different colors.

Comment 1

13 years ago
Created attachment 187746 [details]
color comparison

What's happening is that both of the colors chosen for vistited links and
unvistited links by Firefox are not in the palette. I'm attaching a screenshot
showing both IE's and Mozilla's colors side by side and a propsed new color
from the palette for both. Comments appreciated.

A simple work-around would just be to choose both colors from the palette, or
set them in about:config like the reporter suggested.

I really don't see this as a problem, seeing as how this is the first time such
an issue has been reported.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
Although not directly relating to this one, I suppose, perhaps you would like to take a look at bug #42894 which, if fixed, would give you the ability to select whatever colour you want.

Comment 3

a year ago
I think it's best to close this as duplicate of bug 42894
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 42894
You need to log in before you can comment on or make changes to this bug.