lost all but 2 standard address books

RESOLVED DUPLICATE of bug 299346

Status

Thunderbird
Address Book
--
critical
RESOLVED DUPLICATE of bug 299346
13 years ago
13 years ago

People

(Reporter: Fred Krella, Assigned: Scott MacGregor)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When trying to send a mail through the Firefox "new message" tool, only the
"Personal AB" and the "Collected Addresses AB" showed up. Looking at the
Thunderbird data files (on a different partition on my HD) there are still 1+7
abook.mab or abook-n.mab files existing. So there was some time before (cannot
guarantee that it is linked to the Firefox/Thunderbird action) that the
Thunderbird settings got mixed up.
I noticed in the previous mail session that some folders in my "local folders"
had been 'renamed' to some funny text like "201bbae0" - I don't know whether
that is linked!
Besides that, is there a way to repair the address books from the data? 

Reproducible: Didn't try

Actual Results:  
I renamed the folders in the local folders to correct names.


All this is somehow occurring after updating MS Windows 2000 and MS IE 6 with
"critical updates" from MS ...
Reporter, it would help if we had some more details, please answer the 
following questions:

Did you actually try loading the address book window from thunderbird directly?
Are the address books still there (in thunderbird)?
Can you see the address books when you select "write message" in thunderbird?
What version of thunderbird are you using?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Reporter, it would help if we had some more details, please answer the 
> following questions:
> 
Did you actually try loading the address book window from thunderbird
directly? 

    Affirmative

Are the address books still there (in thunderbird)? 

    They are in Thunderbirds directory but not accessible on the user
    interface level (can I get them there somehow? I succeeded the other
    day to recuperate the folders which were gone ...)

Can you see the address books when you select "write message" in
thunderbird?

    Only the 2 I mentioned, "personal" and "collected"

What version of thunderbird are you using?

    version 1.0 (20041206)
(Reporter)

Comment 3

13 years ago
Hi,
I have further tested working around the problem:
As I explained, there are 8 *.mab files still existing (size .ne zero) in the 
Thunderbird data directory (the basic one and abook-n.mab with n from 1 to 7). 
Only two of them are available at user level, ie in Thunderbird. 
I wanted to test further and declared a new adress book through the program; 
worked ok, put an adress into it and left the program; Ther number of address 
books was ioncreased and a new one in the Thunderbird data directory named 
"abook-8.mab". Hence, Thunderbird sees the lot but cannot link to them; any use 
to you?
Fred
Thunderbird will always create new address book with new names. Hence the 
reason you get the -8 on the end.

Do you know if you ever got any messages about address books being corrupted?

I've set the qawanted keyword as I'd like someone else with Firefox & 
Thunderbird installed to try out the new message from firefox and report back 
as to if the non-default address books disappear or not - I don't have firefox 
or a windows environment set up at the moment.
Keywords: qawanted
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> ....
> 
> Do you know if you ever got any messages about address books being corrupted?
> 
No, definitely not from Thunderbird. The "system" became disturbed around
Thunderbird (and Firefox) after the Windows update I had effectuated, such
message may have been in MS blue screen hidden (corrupted files) of which I had
some...

I've recuperated the lost adress books now by manually defining 6 empty new ones
and making a name exchange with the 6 I could not access; they all work nicely
and it seems I have no addresses lost! Of course I have now 14 address books in
my files of which I only use 1, 8 to 14 and the abook.mab; 2 to 7 are just there
as placeholders.
Fred, another question, do you use google desktop at all?
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> Fred, another question, do you use google desktop at all?

Sorry, I use Google to search occasionally for a term, not really a Google
"desktop" I guess!

Comment 8

13 years ago
I can confirm (repeated several times), that GOOGLE DESKTOP is indeed wiping out
extra address books. The personal address books is untouched.

Google is configured to index mozilla email and other common document types. It
is not configured to share results to to be integrated with web searches.

I normally have gdesktop turned off b ut when I do start it up to index new
documents, that's when things gets trashed. Fortunately, I backup my MABs.

I have also seen my email folders empty out while gdesktop is running. Killing
gdesktop and restarting Thunderbird restores email folders. Compacting needs to
run before folder contents re-appears.
We have recently checked in a couple of bugs that will hopefully fix this or at
least help diagnose it. See bug 299346 and bug 287003. The fix should be in the
latest nightlies, but will most certainly be in the next beta release. Please
comment on those bugs if you are still having problems.

I'm duping this bug to 299346 as that seems the closest one.

*** This bug has been marked as a duplicate of 299346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.