InstallTrigger.getVersion("Plugins/...") returns null even if the plugin is correctly installed.

RESOLVED DUPLICATE of bug 291178

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 291178
13 years ago
10 years ago

People

(Reporter: Vjacheslav Tataurov, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I call InstallTrigger.getVersion() from page's onload handler. When I start
Firefox (by clicking Firefox shortcut) and then open the page, getVersion()
works fine and returns correct plugin version. But when I open the page by
clicking page's shortcut (Firefox starts by assosiation) then getVersion()
returns null.

Reproducible: Always

Steps to Reproduce:
1. Install Flash Player plugin into Firefox
2. Create test.html:
<HTML>
<HEAD>
<script>
alert(InstallTrigger.getVersion("Plugins/Macromedia/Shockwave Flash"));
</script>
</HEAD>
<BODY>
</BODY>
</HTML>
3. Double click test.html in order to open it with Firefox

Actual Results:  
'null' message in the alert box.

Expected Results:  
correct Flash Player plugin version in the alert box.

page reloading doesn't fix the problem.
(Reporter)

Comment 1

13 years ago
Created attachment 187112 [details]
File showing the problem
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
(Reporter)

Updated

13 years ago
Summary: InstallTrigger.getVersion("Plugin/...") returns null even if the plugin is correctly installed. → InstallTrigger.getVersion("Plugins/...") returns null even if the plugin is correctly installed.

Comment 2

13 years ago
Related to/duplicate of Core bug 291178?
(Reporter)

Comment 3

13 years ago
Yes, related. Sorry, I didn't search core bugs before reporting the bug.

*** This bug has been marked as a duplicate of 291178 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.