Java: Always Crash when selecting Help menu->Installed Plug-Ins

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: j4nu5.n6, Assigned: mikepinkerton)

Tracking

({crash})

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O) Gecko/20040906 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O) Gecko/20040906 Camino/0.8+

Crashes when selecting Help menu->Installed Plug-Ins

Reproducible: Always

Steps to Reproduce:
1. Click on Help menu
2. Select Installed Plug-Ins

Actual Results:  
Crashed in 5 seconds

Expected Results:  
showing the about plugin page
(Assignee)

Comment 1

13 years ago
you're using a build that's about 10 months old (20040906). can you try this in
a newer build?
(Reporter)

Comment 2

13 years ago
No, actually I was reporting this bug by a custom build PPC7450 optimized version.

However, I first discovered this bug on the Camino 0.9a1 while I was trying to
verify my zh_TW translation on it.

I have tested it on nightly build 20050618 as well.  Including this Unofficial
build, all three versions always crash.
(Assignee)

Comment 3

13 years ago
works for me with 09a1.
I don't see this either with 2005062208 (v0.9a1+) on 10.3.9 (it takes forever to
load but does't beachball or crash).  Can you *attach* a crash log?

Comment 5

13 years ago
WFM, too.

Yes, attach a crash log!
(Reporter)

Comment 6

13 years ago
Created attachment 187188 [details]
A crash log of the incident

This is the crash log of a single crash.

I have sent back 2 incidents by TalkBack Agent as well.  The incident ID's are:

TB6937069E and
TB6937226W
(Reporter)

Comment 7

13 years ago
I have forgotten to mention.  It is generated by Camino 0.9a1.

Updated

13 years ago
Component: General → Plug-ins
Keywords: crash

Comment 8

13 years ago
WFM too, version 2005062008 (0.9a1) Mac OS X 10.4.1
(Assignee)

Comment 9

13 years ago
looks like a crash starting up java. wonder if maybe he's got a weird java
issue. reporter: does any java content work for you?

Updated

13 years ago
Summary: Always Crash when selecting Help menu->Installed Plug-Ins → Java: Always Crash when selecting Help menu->Installed Plug-Ins
The reporter is running Mac OS X 10.4.1 (Tiger).  He's using a version
of the Java Embedding Plugin (0.9.0) that's incompatible with Tiger.
He needs to upgrade to the current version (0.9.2), which _is_
compatible.

http://javaplugin.sourceforge.net/

Hooray for crash logs! :-)

(Reporter)

Comment 11

13 years ago
Bro Steven,

You are my hero.  After installed JEP 0.9.2, it has been solved!

Thanks a lot!
> After installed JEP 0.9.2, it has been solved!

Glad to hear it, and you're most welcome.

But you should expect to have to upgrade some of your software when
you upgrade to a new OS version (I assume that's what you did).

The Java Embedding Plugin shouldn't have trouble with a "minor
version" OS upgrade (e.g. from OS X 10.4.1 to 10.4.2).  But due to the
fact that the JEP uses undocumented, low-level APIs, current versions
are unlikely to be compatible with OS X 10.5 ... whenever that comes
out (and whatever "cat" it gets named after).

Resolving INVALID as this was an issue with JEP.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 14

13 years ago
Bro Steve,

Sorry for the trouble I have caused.

Yeah, I thought I have the latest JEP installed but obviously I have missed it. ;-P
You need to log in before you can comment on or make changes to this bug.