Deleting multiple rules from a message filter isn't remembered

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Thomas Rutter, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050620 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050620 Firefox/1.0+

When deleteting multiple rules from a message filter by pressing the '-' key
next to them, the deletion isn't remembered after saving and re-editing the
message filter.

Reproducible: Always

Steps to Reproduce:
1. Open Message Filters Window
2. Click "New..."
3. Create a filter with three rules, for example Subject contains 'a', Subject
contains 'b' and Subject contains 'c'
4. Select a filter action, for example 'Mark the message as read'
5. Click OK to save
6. Select the filter you just created and click 'Edit'
7. Delete the last two rules ('b' and 'c') by clicking the '-' button next to them
8. Click OK to save
9. Select the filter you just created and click 'Edit'
Actual Results:  
Two rules remain in the message filter, 'a' and 'c'

Expected Results:  
Only one rule 'a' should remain in the message filter, because the last two were
deleted

Comment 1

13 years ago
version 1.0+ (20050624)

Confirming on the latest nightly. Following the steps to reproduce resulted in
the exact same results reported.

Comment 2

13 years ago
version 1.0+ (20050630)
Reporter, can you still reproduce this? I tried again on 2005-06-30's build and
couldn't seem to. Maybe it's fixed?
(Reporter)

Comment 3

13 years ago
No, it seems to be fixed in 20050705 for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.