XSL Problem: disable-output-escaping="yes" does not work in "value-of" element.

RESOLVED DUPLICATE of bug 98168

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 98168
13 years ago
13 years ago

People

(Reporter: Tom Milner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

This is a XSL translation bug.  Given the XSL statement below,
<xsl:value-of disable-output-escaping="yes" select="description" />
              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The highlighted part of this XSL statement has no effect in FireFox, nor can I
find a work-around.  MSIE 6.0 Win/XP SP2 seems to handle if just fine.

Reproducible: Always

Steps to Reproduce:
1.Try the supplied URL with both browsers.
2.
3.

Actual Results:  
The html formatting characters are displayed, not acted upon.


Without fixing this bug, I can see no way to have formatted HTML pass through
the XML.

Comment 1

13 years ago
Duplicate of Core bug 98168?

Comment 2

13 years ago
Marking duplicate, see question 3 in the FAQ and the duplicate bug:

http://www.mozilla.org/projects/xslt/faq.html#d-o-e

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.