xul error on main window, <menuitem id="menu_HelpPopup_reportertoolmenu" appears on bottom of main window

VERIFIED FIXED in seamonkey1.0alpha

Status

SeaMonkey
Installer
--
major
VERIFIED FIXED
13 years ago
11 years ago

People

(Reporter: baffclan, Assigned: Andrew Schultz)

Tracking

Trunk
seamonkey1.0alpha
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050623
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050623

error shows up on bottom of main window

    <menuitem id="menu_HelpPopup_reportertoolmenu"
____^

Reproducible: Always

Steps to Reproduce:
1. install 2005-06-23-07-trunk build
   the installer with the "-greLocal" command line.
   (see bug 297725 comment 23)


Actual Results:  
error shows up near bottom of window


Expected Results:  
window without error


it is like a bug 297496

Comment 1

13 years ago
Also happen with 2005062402 Creature-Build and new Profil
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Version: unspecified → Trunk
Severity: normal → major

Comment 2

13 years ago
*** Bug 298753 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
The delete of reporter.jar doesn't help. I do not have xul.mfl in the active
profile either.

Comment 4

13 years ago
Created attachment 187288 [details]
the reporter.jar file exists

Comment 5

13 years ago
*** Bug 298778 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

13 years ago
*** Bug 298770 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

13 years ago
It looks like the installer isn't registering this properly

==> installer
Assignee: general → general
Component: General → Installer
QA Contact: general → bugzilla
attachment 186470 [details] [diff] [review] seems to only register a skin and content package, not a
locale one?
(Assignee)

Comment 9

13 years ago
> attachment 186470 [details] [diff] [review] [edit] seems to only register a skin and content package, not 
> a locale one?

the reporter locale files are included with en-US.jar.  I verified that they're
included in the nightly build langenus.xpi file.  But it looks like the
langenus.jst needs to explicitly register the reporter locale files.

Can someone build try this on windows?  For whatever reason, I don't have this
problem on linux.
http://lxr.mozilla.org/seamonkey/source/xpinstall/packager/windows/langenus.jst

   registerChrome(chromeType, cf, localeName + "cookie/");
   registerChrome(chromeType, cf, localeName + "wallet/");
+  registerChrome(chromeType, cf, localeName + "reporter/");
   registerChrome(chromeType, cf, localeName + "content-packs/");
   registerChrome(chromeType, cf, localeName + "help/");
(Assignee)

Comment 10

13 years ago
Created attachment 187315 [details] [diff] [review]
register reporter locale and don't try to register inspector

this also fixes what serge reported in bug 298770 (windows testing desired!)
Assignee: general → ajschult
Status: NEW → ASSIGNED

Comment 11

13 years ago
Comment on attachment 187315 [details] [diff] [review]
register reporter locale and don't try to register inspector

Seems to do the trick :-)
Attachment #187315 - Flags: superreview+
(In reply to comment #10)
> Created an attachment (id=187315) [edit]
> register reporter locale and don't try to register inspector
> 
> this also fixes what serge reported in bug 298770 (windows testing desired!)

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050625] (nightly) (W98SE)

I can't test the patch directly;
but I can confirm that modifying my <installed-chrome.txt> (and deleting
<chrome.rdf>/<xul.mfl> to be sure) fixed the 3 errors:

adding
locale,install,url,jar:resource:/chrome/en-US.jar!/locale/en-US/reporter/
fixes this bug

correcting
skin,install,url,jar:resource:/chrome/reporter.jar!/skin/classic/reporter/
fixes the 2 other errors from my other bug report
Comment on attachment 187315 [details] [diff] [review]
register reporter locale and don't try to register inspector

'approval1.8b3=?':
Trivial 'reporter' chrome registration fix, no risk. (MAS only !?)
Attachment #187315 - Flags: approval1.8b3?
Blocks: 297257
(Assignee)

Updated

13 years ago
Attachment #187315 - Flags: review?(benjamin)
*** Bug 298840 has been marked as a duplicate of this bug. ***
*** Bug 298846 has been marked as a duplicate of this bug. ***
Build ID: 2005062705 still has this bug.  I am not really worried about it. 
But, it seems to take up 5 Windows Taskbar spaces with the message display. :)

Comment 17

13 years ago
(In reply to comment #16)
> Build ID: 2005062705 still has this bug.  I am not really worried about it. 
> But, it seems to take up 5 Windows Taskbar spaces with the message display. :)

As long as this bug is not marked FIXED, we know that the bug is still in the
builds and there's no need to mention that...
Comment on attachment 187315 [details] [diff] [review]
register reporter locale and don't try to register inspector

r=dveditz
Attachment #187315 - Flags: review?(benjamin) → review+

Comment 19

13 years ago
got similar error with 1.8b2 (incl 27.June tarball)
but with different text:
key id="addBookmarkKb key="&addCurPageCmd.commandkey;"
command="Browser:AddBookmark" modifiers="accel,shift"
http://beos.spb.ru/fyysik/BeZilla_DTD_OVerlay_Bug.png
*** Bug 298925 has been marked as a duplicate of this bug. ***

Comment 21

13 years ago
(In reply to comment #19)
> got similar error with 1.8b2 (incl 27.June tarball)
> but with different text:

a different text means a different problem. It's either a different bug or a
problem of your profile.

Comment 22

13 years ago
Per comments 19 and 21
Tested with no profile (so mozilla created new one). Same result
proper screenshot link is 
http://beos.spb.ru/mozilla/BeZilla_DTD_OVerlay_Bug.png
but probably i'll go to file another bug, as advised
*** Bug 299023 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Attachment #187315 - Flags: approval1.8b3? → approval1.8b3+
Checking in xpinstall/packager/os2/langenus.jst;
/cvsroot/mozilla/xpinstall/packager/os2/langenus.jst,v  <--  langenus.jst
new revision: 1.8; previous revision: 1.7
done
Checking in xpinstall/packager/os2/reporter.jst;
/cvsroot/mozilla/xpinstall/packager/os2/reporter.jst,v  <--  reporter.jst
new revision: 1.2; previous revision: 1.1
done
Checking in xpinstall/packager/unix/langenus.jst;
/cvsroot/mozilla/xpinstall/packager/unix/langenus.jst,v  <--  langenus.jst
new revision: 1.26; previous revision: 1.25
done
Checking in xpinstall/packager/unix/reporter.jst;
/cvsroot/mozilla/xpinstall/packager/unix/reporter.jst,v  <--  reporter.jst
new revision: 1.2; previous revision: 1.1
done
Checking in xpinstall/packager/windows/langenus.jst;
/cvsroot/mozilla/xpinstall/packager/windows/langenus.jst,v  <--  langenus.jst
new revision: 1.29; previous revision: 1.28
done
Checking in xpinstall/packager/windows/reporter.jst;
/cvsroot/mozilla/xpinstall/packager/windows/reporter.jst,v  <--  reporter.jst
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 299056 has been marked as a duplicate of this bug. ***
(In reply to comment #22)
> http://beos.spb.ru/mozilla/BeZilla_DTD_OVerlay_Bug.png
> but probably i'll go to file another bug, as advised

Bug 299058 filed.

Comment 27

13 years ago
*** Bug 299087 has been marked as a duplicate of this bug. ***
*** Bug 299115 has been marked as a duplicate of this bug. ***
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050629 on Windows XP Seamonkey trunk.
Status: RESOLVED → VERIFIED
*** Bug 299175 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Seamonkey1.0alpha
(Reporter)

Comment 31

13 years ago
SeaMonkey/2005072305-trunk/WinXP have this problem.
reopen?

Comment 32

13 years ago
(In reply to comment #31)
> SeaMonkey/2005072305-trunk/WinXP have this problem.
> reopen?

No, the same symtom doesn't have to be the same cause, so either use bug 301565
which already has discussion of the new problem or file a new bug about it.

Comment 33

13 years ago
(In reply to comment #32)
> or file a new bug about it.

Actually, no need for it, as this already is a seperate report, see bug 301842
*** Bug 346868 has been marked as a duplicate of this bug. ***

Comment 35

11 years ago
In Seamonkey 1.0.7 this bug is active again.
(In reply to comment #35)
> In Seamonkey 1.0.7 this bug is active again.

Ralf: probably bug 365005.

You need to log in before you can comment on or make changes to this bug.