menu:active { opacity:0.5; } fails to open popup menu

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: mats, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

569 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
menu:active { opacity:0.5; } fails to open popup menu.

I found it while debugging bug 297570 - I have a feeling this block has
something to do with it:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/base/nsCSSFrameConstructor.cpp&rev=1.1105&root=/cvsroot&mark=10331,10427-10447#10410

STEPS TO REPRODUCE
1. load the attached testcase
2. click on the menu item

ACTUAL RESULTS
The text is restyled with 'opacity:0.5' as expected, but the popup menu
does not appear.

EXPECTED RESULTS
the menu pops up

BUILDS & PLATFORMS TESTED
Bug occurs in Mozilla 2005-06-20-02 trunk Linux gtk2+xft
(Reporter)

Comment 1

13 years ago
Created attachment 187250 [details]
Testcase

When clicking on the menu I get:

WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsFrame.cpp, line 2279
###!!! ASSERTION: View is gone, looks like someone forgot to rollup the popup!:
'view', file nsMenuFrame.cpp, line 676
(Reporter)

Comment 2

11 years ago
WFM, with recent nightly builds on Linux and MacOSX.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.