Closed Bug 298735 Opened 15 years ago Closed 15 years ago

text reverts to original color when selected if using font-variant: small-caps with a string not all capitals or all lowercase

Categories

(Core :: DOM: Selection, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 290920

People

(Reporter: eternalsword, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

when selecting text that has the style font-variant: small-caps, the background
color is correctly assigned to the default xp text-selection-background color in
all cases.  The text color, however, reverts to its original color if there are
in  the string letters of a different case.  This is a problem when the text
color on the string is the same or similar to the background color default xp
selected-text-background-color.  I tried the same text selection in internet
explorer which kept the default xp text-selection color, so it is not an os
problem.  If using #316ac5 as the text color on Windows XP with the default
theme, then the problem becomes apparent.  I am not sure if other operating
systems are affected in the same way. 

Reproducible: Always

Steps to Reproduce:
1. Use Windows XP using the default theme
2. Go to http://cs.wheaton.edu/~mbucy/firefoxbugs.htm
3. Select text in the "interspersable cases" line
Actual Results:  
The text disappears once a letter of a different case is encountered.

Expected Results:  
The text should have retained the default XP text-selection color
In Step 1. of reproduction, note that the default theme I am refering to is the
OS theme, not the firefox theme.
*** Bug 298733 has been marked as a duplicate of this bug. ***
Component: General → Selection
Product: Firefox → Core
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 290920 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.