Add Display options for bookmarks bar (display only icon/only name)

RESOLVED DUPLICATE of bug 181649

Status

enhancement
RESOLVED DUPLICATE of bug 181649
14 years ago
14 years ago

People

(Reporter: englabenny, Assigned: mikepinkerton)

Tracking

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050620 Camino/0.9a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050620 Camino/0.9a1

A request: enable us to customize the bookmark bar display. 
Suggested options:
*Favicon and name (default)
*Only name
*Only favicon

The name only option means that we would have to add click feedback on the
bookmark name (currently only the icon changes on mouseDown)
The icon only option would benefit alot if all bookmark favicon were loaded
automatically (bug 223180) or at least just the ones in the bookmarks bar.

Reproducible: Always

Steps to Reproduce:
These options have been WONTFIXed twice already, as bug 181649 and bug 288902.

*** This bug has been marked as a duplicate of 181649 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
What's been WONTFIXed is the GUI for the favicon preference. Which is fine; the
pref works fine in user.js and it functions as expected.

What this bug asks for, and what's been mentioned (but misunderstood) in the two
previous bugs, is a means to turn off icon display in the bookmarks bar
ENTIRELY, leaving only the bookmark titles (a la Safari).

cl
You need to log in before you can comment on or make changes to this bug.