Undo-ing deletion of a mail causes fun

RESOLVED DUPLICATE of bug 209189

Status

defect
--
minor
RESOLVED DUPLICATE of bug 209189
14 years ago
14 years ago

People

(Reporter: webmaster, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Deleting a mail from trash still leaves the opportunity to "undo" this deletion.
However Thunderbird tries to create a "new" mail in the original mail folder
when trying to undo. :)

Reproducible: Always

Steps to Reproduce:
1. Delete any random mail.
2. Now delete it from the trash.
3. Press Ctrl+Z or use undo-function.

Actual Results:  
You see a new, nearly empty except some _random_ header entries, mail created in
the original mail folder where you deleted the random mail.

Expected Results:  
Undo shouldn't have been available at all so the 3rd step wouldn't have done
anything.

Comment 1

14 years ago
This is an interestion bug. I would like to add though that this is a trivial
complaint. In my own personal opinion removing the undo function would be a bad
idea. so all i can say is dont do it.

Comment 2

14 years ago
Related to/duplicate of Core bug 209189?

Comment 3

14 years ago
Agreed on dupe.

Note that reporter is not suggesting removing Undo entirely, only for the case 
where the deleted message is in the trash.  However, that shouldn't be 
necessary; when a message is undeleted from, say, the Inbox, Moz doesn't create 
a new message entry, it simply resets the X-Mozilla-Status flags to turn off the 
Deleted status.  No reason this can't be done in the trash as well.

*** This bug has been marked as a duplicate of 209189 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.