Autocompleted URLs typed with leading scheme/protocol don't complete in the URL field itself.

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: moz, Assigned: sfraser_bugs)

Tracking

({regression})

Details

(Reporter)

Description

13 years ago
Visit a page, leave it, type part of the URL into the location bar *with* the
initial "http://". Press down to select a URL. The field should be filled in
with the rest of the URL's text as it would be if the "http://" was left off,
but it isn't.
Is this the result of smfr's fix for bug 295522?  I've noticed a number of
"strange" behaviors in autocomplete since that patch went in, but none that I
could really pin down solidly.
(Reporter)

Comment 2

13 years ago
It could be; that's what I was thinking, too.
-> simon for a look
Assignee: pinkerton → sfraser_bugs
Keywords: regression
(Assignee)

Comment 4

13 years ago
Yeah, will take a look-see.
Status: NEW → ASSIGNED
This is slightly more annoying with ftp servers, which are often named
ftp.foo.bar, so that you're five characters into the address before autocomplete
starts working.
(Assignee)

Comment 6

13 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.