Last Comment Bug 298904 - Reorganize suite's bugzilla product to accomodate new SeaMonkey project.
: Reorganize suite's bugzilla product to accomodate new SeaMonkey project.
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Administration (show other bugs)
: other
: All All
: -- normal with 5 votes (vote)
: ---
Assigned To: Marcia Knous [:marcia - use ni]
: QA timeless
Mentors:
: 300337 372407 (view as bug list)
Depends on: 417813
Blocks: 301448 325689 387230 450902
  Show dependency treegraph
 
Reported: 2005-06-27 06:32 PDT by Robert Kaiser
Modified: 2011-06-26 22:54 PDT (History)
23 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
List of bmo changes for the SeaMonkey product (11.55 KB, text/html)
2005-06-27 06:34 PDT, Robert Kaiser
no flags Details
placeholder logo (64x64) for report a bug page (2.11 KB, image/png)
2005-07-11 08:58 PDT, Robert Kaiser
no flags Details
Updated list of component changes (12.40 KB, text/html)
2006-03-01 05:37 PST, Robert Kaiser
no flags Details

Description Robert Kaiser 2005-06-27 06:32:25 PDT
Along with rebranding (bug 285696) and newly forming the SeaMonkey project, we
request the "Mozilla Application Suite" product on bmo to be renamed to
"SeaMonkey" and the components being restructured.
I'll attach a list of the changes we like to happen.
Comment 1 Robert Kaiser 2005-06-27 06:34:02 PDT
Created attachment 187401 [details]
List of bmo changes for the SeaMonkey product
Comment 2 Robert Kaiser 2005-06-27 06:47:04 PDT
Perhaps we should add an additional line to the product description I proposed
in the attachment, stating
"Mozilla Application Suite bugs also belong in that component."
Comment 3 timeless 2005-06-27 11:35:21 PDT
oh man. let's move the receipts and offline and whatever bugs to core first. i
rally don't want the categorization lost. some people reasonably presume that
they don't need to list the component in the summary.
Comment 4 timeless 2005-06-27 11:35:52 PDT
further note that we'll need justdave or myk to setup backwards compat when we
rename the product.
Comment 5 Robert Kaiser 2005-06-27 12:42:11 PDT
(In reply to comment #3)
> oh man. let's move the receipts and offline and whatever bugs to core first. i
> rally don't want the categorization lost. some people reasonably presume that
> they don't need to list the component in the summary.

Then we should get those moved to Core soon, please, as we don't want to move
out our new structure for too long. For the most components touched here, the
eventual merging is intentional, as we need to consolidate our project structure.
Comment 6 Robert Kaiser 2005-07-06 08:28:40 PDT
Well, from our (SeaMonkey Council) point of view, we would be good to go for
that change. What do we still need and what can we do to drive it forward?
Comment 7 Robert Kaiser 2005-07-11 08:30:45 PDT
*** Bug 300337 has been marked as a duplicate of this bug. ***
Comment 8 Robert Kaiser 2005-07-11 08:58:11 PDT
Created attachment 188943 [details]
placeholder logo (64x64) for report a bug page

I'm attaching a 64x64 version of our placeholder logo so that it can be used on
the new "report a bug" page once the renaming is done.
Note that we'll need to change this icon later on to our final logo, once we
have one.
Comment 9 Robert Kaiser 2005-07-11 08:58:51 PDT
Comment on attachment 188943 [details]
placeholder logo (64x64) for report a bug page

argh, I'm too used to click "patch" on an attachment :(
Comment 10 Jason Bassford 2005-08-03 11:18:34 PDT
> request the "Mozilla Application Suite" product on bmo to be renamed to
"SeaMonkey"

Just a note that I don't think it should be simply renamed.  Rather, SeaMonkey
should be added as a separate product altogether.  Since, AFAIK, there will
still be a need to track (security) changes specific to the 1.7 MAS branch while
it's still being maintained - won't there?

Also tweaking summary, as I couldn't find this bug on my own.
Comment 11 Jason Bassford 2005-08-03 11:24:57 PDT
Also, from looking at the new component structure, shouldn't Tabbed Browsing be
included as a separate component?  (Distinct from Core, since SeaMonkey may
implement things differently than Firefox in that area.)  Or is it planned to
lump everything with respect to tabs under UI design?
Comment 12 Robert Kaiser 2005-08-03 11:36:24 PDT
(In reply to comment #10)
> Just a note that I don't think it should be simply renamed.  Rather, SeaMonkey
> should be added as a separate product altogether.  Since, AFAIK, there will
> still be a need to track (security) changes specific to the 1.7 MAS branch while
> it's still being maintained - won't there?

Those (hopefully very few) issues are very likely issues that are common to
both, and even more likely to not be suite-specific, so no need for seperate
products here. Additionally, the Mozilla suite may be retired sooner than some
might think, from hearing how tired some MoFo folks are of supporting it.

Creating a new SeaMonkey product, moving almost all open bugs there (as we
usually only track trunk with open bugs) and retiring the old Mozilla suite
product a few months later is just stupid in my eyes. We don't want to have
abandoned Bugzilla products lying around if they still carry history of the same
code as the active SeaMonkey Bugzilla product.
So we should just go and rename it, along with refitting it to the new and
active project's needs.
What we still need is Asa's OK on all that, though.

(In reply to comment #11)
> Also, from looking at the new component structure, shouldn't Tabbed Browsing be
> included as a separate component?

After the move to the toolkit architecture will be complete, I think we will
just be using toolkit's tabbrowser implementation, and everything else will be
just small UI tweaks.
Comment 13 Jason Bassford 2005-08-03 11:45:12 PDT
> Creating a new SeaMonkey product, moving almost all open bugs there
> (as we usually only track trunk with open bugs) and retiring the old
> Mozilla suite product a few months later is just stupid in my eyes.

I agree.  After I posted, I realized I should have said to rename it, but then
also create the original "Mozilla Application Suite" again.  That way all old
bugs get put into the correct product, while there's still some place for
suite-specific bugs.

But if, as you say, there's no need to continue with MAS specifically, then all
is well with the world. :)

> we will just be using toolkit's tabbrowser implementation, and everything
> else will be just small UI tweaks.

Okay, let's hope.  Although, FF does some things quite differently, so I'm not
sure how "small" the UI tweaks might be.  I suppose, if need be, components can
be revisited later.
Comment 14 Robert Kaiser 2005-09-14 05:51:28 PDT
(In reply to comment #3)
> oh man. let's move the receipts and offline and whatever bugs to core first. i
> rally don't want the categorization lost. some people reasonably presume that
> they don't need to list the component in the summary.

OK, bug 292917 is fixed now, and bug 292917 comment 0 says "The shared backend
stuff from "MAS: Offline" and "MAS: Return Receipts" may well go into the
existing "Core: MailNews: Backend" component, so there's no need for extra
components there."

So, basically, it looks we're ready to proceed with this from the technical side.
Asa, can we get an OK for that?
Comment 15 Robert Kaiser 2005-11-06 15:20:11 PST
OK, the "Localization" project area has been dropped by the Council meeting before we finally uploaded our project structure to http://www.mozilla.org/projects/seamonkey/project-areas.html - that means we don't need the new bugzilla component for it as well.

Everything else stays unchanged.

Asa, you already said "that's reasonable" on IRC some time ago, could you give a formal OK here so we can get this done?
Comment 16 Robert Kaiser 2006-02-01 12:49:48 PST
Comment on attachment 188943 [details]
placeholder logo (64x64) for report a bug page

This has been obsoleted by the real logo, which is available as a 64x64 version at http://www.mozilla.org/projects/seamonkey/images/seamonkey64.png
Comment 17 Robert Kaiser 2006-02-13 12:42:22 PST
As a note for those who are CCed here, we have the OK from Asa on this now, and we are in contact with the people who actually can work on it.
This is a big change though, needing movement of many bugs to the new/consolidated components, and it might take some time until that can really be done. We are working on it though.
We also have done some tweaks to the list, I'll attach the new version here once we are satisfied with those changes going live as shown on that version.
Comment 18 Reed Loden [:reed] (use needinfo?) 2006-02-13 15:29:10 PST
marcia is now the default assignee for Bugzilla: Keywords & Components.
Comment 19 Robert Kaiser 2006-03-01 05:37:34 PST
Created attachment 213575 [details]
Updated list of component changes

As I got no further comments on our proposed reorganization, here's the updated list of component changes for the suite product.

We've done some minor changes and corrections, the basics stayed unchanged though.
Comment 20 Marcia Knous [:marcia - use ni] 2006-03-28 17:48:55 PST
Robert: Is this ready to go, and we just need to coordinate a date to do this?
Comment 21 Robert Kaiser 2006-03-29 02:50:25 PST
Marcia:
Yes, it's ready to go.
We're only waiting on someone to do the work of merging a bunch of components and doing all the renaming (and account creation/reuse for the new watchable addresses).
Comment 22 Steffen Wilberg 2006-04-21 09:33:30 PDT
I filed a couple of bugs to move components from Core to Suite/SeaMonkey:
- Core:Tabbed Browser (bug 334545)
- Core:Location Bar (bug 334959)
- Core:Keyboard: Navigation (bug 334960)
- Core:Search (bug 334962)
- Core:Themes (bug 334964)
Comment 23 Robert Kaiser 2006-06-16 12:59:50 PDT
What can we do to make this actually happen?
Comment 24 Marcia Knous [:marcia - use ni] 2006-06-16 17:09:44 PDT
I can do some of the actual work, but it sounds as if this needs involvement from justdave as well. Let me talk to him about the easiest way to do this and after I do that I will post an update in the bug.


(In reply to comment #23)
> What can we do to make this actually happen?
> 

Comment 25 Marcia Knous [:marcia - use ni] 2006-06-26 10:36:34 PDT
justdave and I are meeting this week to talk about planning when we will do this - the script has to be complete and then we have to plan a time to do it.
Comment 26 Philip Chee 2006-06-28 09:51:58 PDT
According to bug 282178 there are still significant differences between xpfe and toolkit tabbrowsers. Most recently I think there is the tab previews in xpfe and scrolltabs in toolkit/browser.

So I think there should still be a separate tabbrowser component for SeaMonkey if we want to retain SeaMonkey specific features which might not make it into the toolkit tabbrowser.
Comment 27 Robert Kaiser 2006-06-28 10:16:23 PDT
(In reply to comment #26)
> So I think there should still be a separate tabbrowser component for SeaMonkey
> if we want to retain SeaMonkey specific features which might not make it into
> the toolkit tabbrowser.

This would be a new component anyways, and this can be created after this current bug has been resolved (and it needs to be discussed first).
For now, xpfe/suite tabbrowser bugs belong to the "UI design" component of the SeaMonkey product (see attachment).
Comment 28 thomasasta 2006-08-21 13:44:34 PDT
Hello Robert

can you add the open serverless p2p Instant Messenger to seamonkey installer ?

http://cspace.in

Thanks
Comment 29 Robert Kaiser 2006-08-21 18:05:28 PDT
comment #28 is completely unrelated to this bug and probably WONTFIX anyways.

That said, what's the status on this? marcia? justdave?
Comment 30 Robert Kaiser 2006-09-20 11:57:11 PDT
Comment on attachment 213575 [details]
Updated list of component changes

marcia/justdave:
What is blocking this bug at the moment? Anything we can do to help it getting along?
Comment 31 Marcia Knous [:marcia - use ni] 2007-02-20 10:57:15 PST
I will talk to justdave about this today and see if we can get some traction on this. 
Comment 32 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-03-02 11:39:03 PST
*** Bug 372407 has been marked as a duplicate of this bug. ***
Comment 33 Robert Kaiser 2007-06-14 13:56:56 PDT
The big Bugzilla reorg is being discussed in m.d.planning, and I did throw in this change as well once again.


A few small changes to the list came up when I thought about it once more from a current point of view and cleared even more things up (I'll noted those on the newsgroup as well, discussions should be done there):

- Instead of creating a new SeaMonkey::Themes component, Core::Themes should move into SeaMonkey and get the desc, etc. we have in the SeaMonkey list. The current component in Core does only track SeaMonkey's default and Modern themes, actually.

- Core::Search is also suite only and should move to the SeaMonkey product.

- Core::Location Bar is another such case, move it.

- same with Core::Tabbed Browser

- We might want to rename Bookmarks to "Bookmarks and History", including history UI in preparation of using places backends, but I got to discuss that with other SeaMonkey people first.

- We shouldo rediscuss with MailNews folks which MailNews components really belong to SeaMonkey and which to a shared product. 
Comment 34 Robert Kaiser 2008-08-15 15:13:01 PDT
This has been FIXED by the big Bugzilla reorg. Please file any errors that were made as dependencies on this bug and bug 448639 and file any additional things coming up as new bugs.

Note You need to log in before you can comment on or make changes to this bug.