extensions manager freeze when opening disabled extensions options

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
minor
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Jerry Chong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050621 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050621 Firefox/1.0+

When clicking on the Options button while selecting an extension that was
disabled due to version incompatibilty the extension manager window stops
responding. The Deer Park window is not affected.

Reproducible: Always

Steps to Reproduce:
1. Install a 1.0.x-only compatible extension (i.e Greasemonkey 0.3.3)
2. Upgrade to 1.0+. Said extension will be auto disabled.
3. Open extensions manager, select the disabled extension, and click Options.

Actual Results:  
The Extension Manager freezes.

Expected Results:  
Inform the user that the extension has been disabled, or do nothing at all.
This was a recent regreession and was fixed by bug 298186 which landed on the
same day as the build you are using. Try a current nightly build and if it is
fixed please close this bug as works for me.
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.