[Mac] Cannot launch trunk Thunderbird built against 10.3 SDK

RESOLVED FIXED

Status

Thunderbird
Build Config
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Frederic Bezies, Assigned: Mark Mentovai)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

850 bytes, patch
Scott MacGregor
: review+
peterv
: superreview+
Benjamin Smedberg
: approval-aviary1.1a2+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050628 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050628 Firefox/1.0+

This is a simple to describe. I built under Tiger 10.4.1 and gcc 4.0 from XCode
2.1 a Thunderbird from trunk.

Build process is going to its "normal" end.

After that, I build the package using make -C mail/installer.

But when I try to launch thunderbird using the Thunderbird.app package, nothing
happens.

So, I tried to launch thunderbird-bin from the package.

And I get this error message :

dyld: lazy symbol binding failed: Symbol not found: _PL_InitArenaPool
  Referenced from:
/Users/frederic/Documents/logs/thun/mozilla/dist/Thunderbird.app/Contents/MacOS/./thunderbird-bin
  Expected in: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

Reproducible: Always

Steps to Reproduce:
1.Build a thunderbird on mac using gcc 4.0 from XCode 2.1
2.Package it
3.Try to launch it

Actual Results:  
Thunderbird dies :(

Expected Results:  
Thunderbird alive and working.

Here is the .mozconfig used :

 sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#

. $topsrcdir/mail/config/mozconfig

# Options for 'configure' (same as command-line options).
ac_add_options --with-macos-sdk=/Developer/SDKs/MacOSX10.3.9.sdk
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize=-O2
ac_add_options --enable-prebinding
ac_add_options --disable-shared
ac_add_options --enable-static

Gcc is :

Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5026.obj~19/src/configure
--disable-checking --prefix=/usr --mandir=/share/man
--enable-languages=c,objc,c++,obj-c++
--program-transform-name=/^[cg][^+.-]*$/s/$/-4.0/
--with-gxx-include-dir=/include/gcc/darwin/4.0/c++ --build=powerpc-apple-darwin8
--host=powerpc-apple-darwin8 --target=powerpc-apple-darwin8
Thread model: posix
gcc version 4.0.0 (Apple Computer, Inc. build 5026)
(Assignee)

Comment 1

13 years ago
Mac link order problem, taking.

Frederic, in the mean time, you can use the 10.4.0 SDK.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

13 years ago
Whoops, meant to take for myself.

Component and severity adjusted properly.
Assignee: mscott → mark
Severity: critical → normal
Status: ASSIGNED → NEW
Component: General → Build Config
(Assignee)

Updated

13 years ago
Summary: [Mac] Cannot launch a gcc 4.0 build based Thunderbird trunk. → [Mac] Cannot launch trunk Thunderbird built against 10.3 SDK
(Assignee)

Comment 3

13 years ago
Created attachment 187557 [details] [diff] [review]
Link order fix

TK_LIBS has the Cocoa and Carbon frameworks and brings in libSystem.  With the
10.3 SDK (including SDK-less builds on 10.3), libSystem must come after the
NSPR and NSS libraries because it contains implementations of NSPR and NSS. 
libSystem on 10.4 (and 10.2) don't, so with libSystem linked earlier than the
build's NSPR and NSS libraries, an app that won't run on anything other than
10.3 is produced.

Ah, the joy of the two-level namespace.

I doubt that moving TK_LIBS will affect other platforms, but I haven't tested
it.

This change was also necessary in gfx/src/mac in bug 292530, but that was
Mac-specific.
Attachment #187557 - Flags: superreview?(peterv)
Attachment #187557 - Flags: review?(mscott)

Updated

13 years ago
Attachment #187557 - Flags: review?(mscott) → review+
(Reporter)

Comment 4

13 years ago
Patch is working :)

I was using a source up-to-date on 28 june - 10:30 pm, mozilla.org time.

Let's hope it could be added soon on trunk ;)
Attachment #187557 - Flags: superreview?(peterv) → superreview+
(Assignee)

Updated

13 years ago
Attachment #187557 - Flags: approval-aviary1.1a2?

Comment 5

13 years ago
Comment on attachment 187557 [details] [diff] [review]
Link order fix

a=bsmedberg for landing today (6/29)
Attachment #187557 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
(Assignee)

Comment 6

13 years ago
Will land this afternoon EDT.
(Assignee)

Comment 7

13 years ago
Checking in mail/app/Makefile.in;
/cvsroot/mozilla/mail/app/Makefile.in,v  <--  Makefile.in
new revision: 1.45; previous revision: 1.44
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 8

13 years ago
could this check in have caused the mac tinderbox build for thunderbird to go red?

http://tinderbox.mozilla.org/showbuilds.cgi?tree=Thunderbird
(Assignee)

Comment 9

13 years ago
No, boxset's build is stopping in libxpcom, long before hitting
mail/app/Makefile.  If I had to guess quickly, I'd say bug 298047.
You need to log in before you can comment on or make changes to this bug.