Closed Bug 299002 Opened 16 years ago Closed 16 years ago

export rss feeds

Categories

(MailNews Core :: Feed Reader, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 283735

People

(Reporter: Peter.Dedecker, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050516 Firefox/1.0.4
Build Identifier: 

Shouldn't it be good to include an export function voor the RSS-feeds you're
subscribed to?  This way, you can export all the RSS-url's to a file (plaintext
or xml) and import that list in another installation of TB or another program. 
You can, for example, give your list of subscribed feeds to a friend with the
same interests so he could import those feeds, eventualy only a selection of
feeds he wants to include/exclude.

Reproducible: Always



Expected Results:  
Click your right mousebutton on the RSS-account and select "export feeds".  A
window appears with a list of your feeds and a selection button next to it.  You
can use the buttons "select all" of "deselect all".  When you made your
selection, you can press the "export button" wich asks you where to save the
file and with what name.

Click your right mousebutton on the RSS-account and select "import feeds".  A
file selection window appears.  After choosing the right file, a window appears
with a list of feeds in that file with a selection button next to each feed. 
Feeds that are allready in your RSS-account(s) are automatically excluded.  You
can select or deselect the feeds you want to import.  After pressing the import
button, you are subscribed to the feeds with your RSS-account (eventually select
wich account).
The option to import/export feeds in OPLM format exists in trunk. See bugs
283735   and 258102, and get the latest trunk at http://tinyurl.com/8wc3t.
Fine, thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Reopened to fix resolution.

*** This bug has been marked as a duplicate of 283735 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.