Keyboard focus in browser lost after clicking on a Swing applet's component

RESOLVED DUPLICATE of bug 247140

Status

()

Firefox
Keyboard Navigation
--
critical
RESOLVED DUPLICATE of bug 247140
13 years ago
13 years ago

People

(Reporter: John Abraham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/312.1 (KHTML, like Gecko) Safari/312
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

After pointing browser to the URL above and the applet has loaded, click on the 'Fonts' pulldown menu 
and select an option, say 'American Typewriter'.
Try clicking in the browser URL text entry box and type something to change the URL - you cannot.
It appears that the keyboard focus stays in the applet - if you type in the character 'c' for instance while 
the mouse focus is in the URL textbox, notice that the selection in the 'Fonts' pulldown of the applet 
changes to 'Century Gothic'.

Reproducible: Always

Steps to Reproduce:
1. Go to URL above.
2. Click on a selection in the 'Fonts' pulldown - and select 'American Typewriter'.
3. Click in the URL textbox to change the URL and you cannot.

Actual Results:  
keyboard focus appears to stay in the applet, while mouse focus is in the URL textbox.

Expected Results:  
keyboard focus should have moved to where the mouse was clicked.
(Reporter)

Comment 1

13 years ago
this can also cause a crash in Firefox.
At step 3, type something like 'c', say, then hit the reload URL button. Repeat a few times, and the 
browser should crash.
(Reporter)

Comment 2

13 years ago
Created attachment 187697 [details]
crash incident file

Comment 3

13 years ago
Related to/duplicate of Core bug 247140?
(Reporter)

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 247140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.