Mac OS X 10.3 with Xcode 1.5 is the new minimum build environment (10.4/2.2 for universal)

RESOLVED DUPLICATE of bug 327092

Status

Webtools Graveyard
Tinderbox
--
critical
RESOLVED DUPLICATE of bug 327092
13 years ago
4 years ago

People

(Reporter: Mark Mentovai, Assigned: coop)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

13 years ago
Due to bug 298047 and other headaches associated with maintaining support for
ancient build environments, the new minimum is Xcode 1.5, which only runs on
10.3.  This applies to the fox, bird, lizard, and whatever animal represents
Camino.  (pink panther?)

Cleanup:

There's currently a workaround in place, introduced in bug 292530 (but what
wasn't?), to support old-style Project Builder project directories (.pbproj)
adjacent to new-style Xcode ones (.xcode).  This workaround should be removed,
as should checks for other things specific to Project Builder or pre-1.5 Xcode.
 Things that refer to pbbuild and pbxbuild can disappear.  It's xcodebuild from
here on out.

The workaround was present in:

embedding/components/printingui/src/mac/printpde
modules/plugin/samples/default/mac

This bug depends on updating the tinderboxen to meet the new minima.

Comment 1

13 years ago
Bug 298047 was backed out due to tbox red until we can upgrade enough of them to
get good test coverage. While it is not strictly necessary to land that for 1.8,
it is really kinda necessary in order to get a reasonable xulrunner preview
release... I don't know how we want to proceed from here.
Blocks: 298047

Updated

13 years ago
Blocks: 214164
(Reporter)

Updated

13 years ago
Blocks: 300047
(Assignee)

Comment 2

13 years ago
Chase and I (read: me) can probably find some time to upgrade Xcode on the Macs following the 1.5 rc release.

Comment 3

13 years ago
(In reply to comment #2)
> Chase and I (read: me) can probably find some time to upgrade Xcode on the Macs
> following the 1.5 rc release.

Let's inventory the systems that need to be upgraded and post here those systems and build trees that will be affected.
(Reporter)

Comment 4

13 years ago
I know that atlantia, columbia, and triton have current build tools.  I'm pretty sure the rest are out of date.

All 10.3 boxes should be updated to Xcode 1.5 with the November 2004 gcc update (a separate installation).  10.4 boxes, if you choose to do any of those, should have Xcode 2.1 or higher (not 2.0).  There's been talk among the Camino developers to make changes that would require Xcode 2.1.

The Seamonkey boxes are still running Jaguar and will need a major OS upgrade to at least 10.3.
(Reporter)

Updated

13 years ago
Blocks: 300947

Comment 5

13 years ago
Coop, chase, can we bump this up the priority list a little once ffox 1.5 is out the door?
Assignee: mark → ccooper
Component: Build Config → Tinderbox Configuration
Product: Core → mozilla.org
Version: Trunk → other

Updated

13 years ago
Blocks: 313309
(Reporter)

Updated

13 years ago
Blocks: 322578

Updated

13 years ago
Blocks: 325065
(Reporter)

Comment 6

13 years ago
Consider the warning shot to have been fired.

Very soon, bug 322578 will land, and this will completely kill the build on any Mac that's unfortunate enough to still be running 10.2.  If the SeaMonkey tinderboxes haven't been upgraded by the time this lands, they will catch fire.  This is an integral part of the universal binary strategy, and we can't hold this work for SM tinderbox upgrades.  Sorry, guys, but the Jaguar ship is sailing.

In addition, there are a number of tinderboxes still running Panther (10.3) that need their Xcode Tools bumped up to 1.5.  The updated toolchain is necessary to support continued development of XULRunner.  This work too is becoming too important to hold for tinderbox upgrades.

Any machine that produces a universal build MUST be upgraded to Tiger with Xcode 2.2 or later.  This includes ALL of the Camino tinderboxes.  Any machine that produces native-only builds MUST be upgraded to at least 10.3.9 with Xcode 1.5.

Bang.
Summary: Mac OS X 10.3 with Xcode 1.5 is the new minimum build environment → Mac OS X 10.3 with Xcode 1.5 is the new minimum build environment (10.4/2.2 for universal)
(Reporter)

Updated

13 years ago
Severity: normal → critical
(Assignee)

Comment 7

13 years ago
Bug 327092 is where the action is on this.

*** This bug has been marked as a duplicate of 327092 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.