[ANNOYING] M14 build does not identify itself as M14 build.

VERIFIED WONTFIX

Status

SeaMonkey
Installer
P3
trivial
VERIFIED WONTFIX
18 years ago
13 years ago

People

(Reporter: Jason Eager, Assigned: use leaf@mozilla.org)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
My M14 talkback binary that I downloaded from the release directory
identified itself as "Build ID: 2000022916"

I think it should identify itself as "Build ID: M14".

Yes, this is trivial, but it is also ANNOYING for us testers who have 5
or 6 different binary builds on our systems, after running moziila
for a while. we forget which version we're running, so when a bug occurs,
we're going to say that we're running NIGHTLY BUILD 2000022916, instead
of saying that we're running M14. Saying the latter would make it
MUCH easier for other people to reproduce the bug.

Besides, SOME kind of graphical distinction should be drawn between
NIGHTLY Builds and Milestone builds, since Nightly builds often suffer
from one kind of temporal problem or another...a "stupid" bug or breakage
that can be fixed within a day or so. Milestone builds shouldn't
suffer from those problems, and any bugs detected in those should
be analysed more closely, they are indications of the "deeper" bugs.

Finally, it gives novices a clear indication about whether this is a
nightly build or a milestone build.

Comment 1

18 years ago
Since M14 has been released I don't know if they will make this change but
changing component to Build config just in case.
Assignee: cbegle → cls
Component: Browser-General → Build Config
QA Contact: asadotzler → cyeh

Comment 2

18 years ago
*** Bug 29881 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
This isn't handled by build config.
Assignee: cls → leaf
Component: Build Config → Installer

Comment 4

18 years ago
Sorry, the buildid is for talkback purposes, and having buildid's based on
datestamp are the right way to handle talkback reports.

The *right* thing to do is display the user agent, and maybe make the buildid
incorporated there. The next set of M14 release candidates will have the correct
user agent. Marking wontfix.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 5

18 years ago
*** Bug 30450 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 30573 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
*** Bug 31495 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
verifying- M14 is long gone
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.