Unable to move 100+ messages from one IMAP folder to another

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: bzbarsky, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
BUILD: Current trunk build.

STEPS TO REPRODUCE:

1)  Highlight 150 messages in an IMAP folder
2)  Try to move them to another IMAP folder

EXPECTED RESULTS:  Messages moved

ACTUAL RESULTS:  Messages copied to the new folder, then a "connection timed
out" message.

NOTE:  This means that I now have to manually deal with all the spam I got while
on vacation, since the same error occurs when mailnews tries to move the spam to
the Junk folder...

Could this be fallout from the work on letting sockets time out?
(Assignee)

Comment 1

14 years ago
these folders are on the same server? It's pretty unlikely - we issue the single
command to copy the messages, and then wait for a response, then delet the
original messages. If it takes a really long time on the server, then I suppose
it could time out, but it would have to be a really slow server. You can try
increasing the timeout and see if it helps, under tools | options | advanced
(Reporter)

Comment 2

14 years ago
Yes, the folders are on the same server.  We copy fine, the delete times out.

I'll try bumping the timeout and seeing what I get....
(Reporter)

Comment 3

14 years ago
I don't see a mailnews option to change this timeout in the suite... Is there one?

In any case, I manually changed the pref value to 300, and I get the same exact
result.  The messages are copied, but the delete times out.  This is with 167
messages that I was trying to move.
(Assignee)

Comment 4

14 years ago
it could be that the server isn't generating the right protocol as a response to
the copy or the delete, so we timeout waiting for it.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 5

14 years ago
Created attachment 188722 [details]
IMAP:5 log from startup to getting the timeout alert

Ah, excellent.	This is a log of the problem happening.
(Assignee)

Comment 6

14 years ago
my educated guess is that we're generating too long a command string to do the
copy, and the server is hanging, and not returning an error. This is a dup of an
existing bug, I'm pretty sure. I fixed this for the storing of flags, but not
COPY. There are two possible fixes, generating ranges and doing the copy with
multiple commands.
(Assignee)

Comment 7

14 years ago
this is only a problem on some servers.
(Reporter)

Comment 8

14 years ago
Bug 221509 may be related, but it's hard to tell what the heck that bug is
actually about....

I realize this may only be a problem with some servers.  I just don't have much
choice of IMAP server here, and this bug pretty totally hoses spam filtering any
time I don't check email for more than a day or two.  :(
(Assignee)

Comment 9

14 years ago
Bug 221509  was not what I had in mind :-) there's one with a much better
description of the problem and solutions.

the problem for coalescing the ranges is that the info I need isn't readily
accessible at the time I need it. I'll have another crack at it this weekend. My
condolences, it's highly unfortunate that MIT settled on that rev of the server
(Assignee)

Comment 10

14 years ago
Created attachment 188877 [details] [diff] [review]
proposed fix

break up copy into multiple commands, if command line gets long (over 950
bytes)
Assignee: nobody → bienvenu
Status: NEW → ASSIGNED
Attachment #188877 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #188877 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

14 years ago
Attachment #188877 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #188877 - Flags: approval-aviary1.1a2? → approval1.8b4+
(Assignee)

Comment 11

13 years ago
fix checked in. Let me know if this fixes it for you, thx!
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

13 years ago
Yeah, the move is near-instantaneous now.  Thanks!
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

13 years ago
*** Bug 280088 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.