<html:p> ... </html:p> breaks "flex"

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Tennessee Leeuwenburg, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+

I have a tabbed pane, one of which has an <html:p> element. The p doesn't wrap
to the size of the tabbed pane - instead the pane becomes the full width
required to display the text on one line. This is bad.

Reproducible: Always

Steps to Reproduce:
<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<window
    id="findfile-window"
    title="Bureau of Meteorology Data Viewer"
    orient="horizontal"
    xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
    xmlns:html="http://www.w3.org/1999/xhtml"
    align="start"
>

    <vbox style="margin: 45px;">

    
        <tabbox id="controls" width="350" flex="0">
            <tabs>
                <tab label="Controls"/>
		<tab label="Data Finder"/>
                <tab label="Help!"/>
            </tabs>
            <tabpanels height="450" width="350" flex='0'>
                <tabpanel id="control-tab" orient="vertical">
                
                </tabpanel>
		
		<tabpanel id="data-tab" width="350" flex="0">
			<html:p>
				There are many data sets available for inclusion in the Bureau of
Meteorology Data Viewer. Any web services
				capable of producing images can, in theory, be included. Only web service
conforming to the Bureau standard
				for time-series images can be incorporated into an animation, however. The
form below will allow you to add
				various pre-selected data sets, or allow you to link into an external web
service.
			</html:p>
		</tabpanel>
                
                <tabpanel id="help-tab">
                        <browser src="help.html" type="content" height="350"
width="350" flex="1" />
                </tabpanel>
            </tabpanels>
        
        </tabbox>
    
    </vbox>
    
</window>
(Reporter)

Comment 1

13 years ago
Actually, the checkbox-depressed thing seems to be related to platform, rather
than how many there are. Tech me for doing two things at once. The problem
happens every time for each checkbox under linux, and never under windows.
That sounds like the right layout for XUL last I checked...

Comment 3

13 years ago
I don't understand what comment 1 is doing here, but putting HTML in XUL is bad as HTML uses a block layout while XUL uses a box layout. Fortunately we have block to box adapters which are invoked via the <label> and <description> elements, e.g. <label>any inline or block HTML can go here</label>.

As a side note, there is no such XUL element as tabpanel. If you need multiple elements in a single tab, simply wrap them in e.g. a vbox element as required.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.