Bad attribute-value normalization WRT white space

RESOLVED DUPLICATE of bug 121040

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 121040
13 years ago
13 years ago

People

(Reporter: Nowhere man, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

According to the XML specification, a sequence of white spaces in attribute
value should be converted in onyl one white space, but it is not the case.

Reproducible: Always

Steps to Reproduce:
1. Loads the page
2. Hover the cursor over the THERE word (abbr tag with title) for the poput to
appear
3. See first two words badly separated by white spaces.

Actual Results:  
See first two words badly separated by white spaces.
-> "Multiple      whitespaces shoudl be rendered as one whitespace"

Expected Results:  
White spaces should be normalized to one.
-> "Multiple whitespaces shoudl be rendered as one whitespace"

http://www.w3.org/TR/REC-xml/#AVNormalize

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 121040 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: Bad attribute-balue normalization WRT white space → Bad attribute-value normalization WRT white space
You need to log in before you can comment on or make changes to this bug.