Command-clicking on multiline/wrapping link in a table cell selects the table cell.

RESOLVED FIXED

Status

()

Core
DOM: Events
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Wevah, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
The summary says it all: command-clicking on a wrapping link in a table cell
selects the table cell (which it shouldn't do).

Quite noticable on Slashdot, for example.

Can someone check and see if this happens on Windows with control-click (or
whatever the key-combo is for "open in new tab")?

Comment 1

13 years ago
worksforme with linux ctrl-click using suite trunk build 2005070105

what build are you using?
(Reporter)

Comment 2

13 years ago
I'm using the Camino build from June 28th. It could be Mac, only, I suppose.

FWIW, the second or later line of the wrapped link has to be clicked; the first
line, even if it's flush left, won't cause the bug.

Command-click is both "open link in new tab/window" and "make discontinuous
selection", also, which might be confusing something, somewhere.

Comment 3

13 years ago
I see this every day. On the BBC site, try command-clicking one of the longer
"Also in the news" links on the RHS.

Comment 4

13 years ago
This seems to be Camino only. It seems to happen iff:
1. the link wraps.
2. the link is not already focussed
3. you command-click the 2nd or subsequent lines of the link
Component: Event Handling → Page Layout
Product: Core → Camino

Comment 5

13 years ago
This reminds me of bug 255378.

Comment 6

13 years ago
Just as in bug 255378, removing the -moz-any-link:focus from us.css makes the
problem not occur.
so does that mean it's our problem or core?
Component: Page Layout → DOM: Events
Product: Camino → Core
Not sure, actually... I suspect core, but I could be wrong.

Comment 9

13 years ago
...but it doesn't happen in FF. Weird. Maybe we have different flags on the mouse click events??
It looks to me like something fixed this recently on the trunk, perhaps bug 333481?
Setting this to FIXED-on-trunk because I'm pretty sure the fix for bug 333481 fixed this (and none of the regression fixes for that bug have broken it).
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.