Closed Bug 299423 Opened 14 years ago Closed 11 years ago

[th] Thai: Firefox

Categories

(Mozilla Localizations :: Registration & Management, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: markpeak, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050630 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050630 Firefox/1.0+

the product you want to localize: Firefox
the language + country code: th-TH
your contact details (name + e-mail, web-page if available).: Isriya
Paireepairit <markpeak@gmail.com>

We have done localization for Firefox
(http://www.isriya.com/firefox-thai-langpack) and localize build
(http://www.actiwhiz.com/firefox/) already. This is only a registration bug.

Due to some technical issues about Thai wordbreaking, we need to patch Firefox
to build a usable browser for Thai. However we got a grant  from  Mozilla
Foundation (Gervase Markham ) to use Community Edition theme already.

https://bugzilla.mozilla.org/show_bug.cgi?id=226420 is a tracker bug for Thai
localization in Mozilla.

Reproducible: Always
I've sent an email to licensing@mozilla.org asking for permission to use the
name Thai Firefox/Thunderbird community edition because Thai need a patch to
apply for the binary to be usable. Gervase says it's OK to use the name and
encourage us to work toward making official builds.
I added your team to our wiki page [1]. Could you clarify who is supposed to be
the owner and who peer [2]?

Please try to start working on trunk. Please apply for a CVS account - see bug
263726 as an example

1] http://wiki.mozilla.org/L10n:Localization_Teams
2] http://wiki.mozilla.org/L10n:Ownership
Status: UNCONFIRMED → NEW
Ever confirmed: true
I just add myself and Samphan as owner in L10N Wiki page. 
(In reply to comment #3)
> I just add myself and Samphan as owner in L10N Wiki page. 

Isriya, there can be only one owner - the one who is be responsible for 
communication within the Mozilla Project. 
I'd like to add that the owner of a project is determined by the Mozilla Project,
in this case, mlp-staff.
That is, any change in ownership needs to be approved by mlp-staff, and needs a
bug report.
Ah, sorry. I just see some langauges have 2 owner, then I edit the wiki.

I should be Thai localization owner. CVS requestion is bug #300630
Depends on: 300630
Adding Brian to CC as he's mentoring Zek Kelley on google's soc.
(In reply to comment #7)
> Adding Brian to CC as he's mentoring Zek Kelley on google's soc.

This request for registration was not made by Zek. Basically, when the project
was accepted we were not aware that other developers has already stepped up for
the Thai localisation.

So the project has shifted focus, and Zek is translating other projects such as
Camino.

http://thailocalization.mozdev.org/
Duplicate of this bug: 369826
Fixing up the dependencies, adding the layout problem as blocker here.
Blocks: 300630
Depends on: 7969
No longer depends on: 300630
Summary: Registration for Thai (th-TH) Firefox localization → [th-TH] Thai: Firefox
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
Gervase, I'm still interested to do localization in Firefox and Thunderbird.
Isriya, it seems that Firefox 3 will be the first version that doesn't dramatically suck on at least Linux. Windows and Mac seem to be unresolved still, but maybe we get volunteer power for those once we have something on at least one platform.

Anyway, moving forward, http://wiki.mozilla.org/L10n:Starting_a_localization documents on how we should move forward. I'm not really sure how much existing work we have, and in which form, but there seems to be something to build upon.

The bad news is, we don't have a freeze date for Firefox 3, the schedule for that is on http://wiki.mozilla.org/Firefox3/Schedule, as far as we have it. That page will be updated according to what we know as we go.
PS: we prefer short locale names these days, that is, we prefer th over th-TH, unless there's a significantly different dialect of Thai spoken outside Thailand.

Would it be ok to just go for "th"?
Axel:

- I don't understand your statement that "Firefox 3 will be the first version that doesn't
dramatically suck on at least Linux. Windows and Mac seem to be unresolved" since line-breaking issues are resolved on three major platforms.
(See: Bug #336959 [Linux], Bug #389520 [Mac], Bug #390048 [Win])

- It seems that we need to start from scratch for Firefox 3. Anyway, Thai team is ready for this job. I just only make sure that we will get write access on the tree.

- "th" is ok
Oh, sorry, didn't see the other platforms actually getting fixed.

Regarding the starting from scratch, you may not have to do that, if there are existing resources out there. That's hard to document though, of course, so that will depend on what's out there. If there is (I didn't do a full research, but I guess), there will be ways to help you with that, asking in the mozilla.dev.l10n newsgroup is the best idea for that.

For the cvs write access, we'll deal with that once we have something to review here, that's described in http://wiki.mozilla.org/L10n:Localization_Process and it's child pages, in particular in the second part.
Summary: [th-TH] Thai: Firefox → [th] Thai: Firefox
Isriya: How are things going? Have you been able to make any progress?

Gerv
Gerv: I talked with Axel in #65896 (see https://bugzilla.mozilla.org/show_bug.cgi?id=65896#c52). Waiting for his response.
Blocks: thai-l10n
Hi Isriya, I just see that there are many things one the web for the thai localization, sadly, I can't find a source. I've found po files and language packs, but what I need is the source code, i.e., the dtd and properties files and all their friends on the structure that we use on cvs.mozilla.org.

Please create a tar.gz for that and attach that to this bug? Then set the review flag to '?' and enter my bugmail address as requestee.

Sorry for the late notice on that, I saw enough indications flying by that made me confident that I'd just had to open the bug and would find what I'm looking for.

PS: If you're converting from po to moz files, please make sure to use the latest version of the translate toolkit, we found a few bugs in that in the last half year.
Axel,

The Thai team now is working on QA for remaining Thai issues on our own build. We will notice the progress in this bug. When it'll be good enough, we will publish the tar.gz here.
I reshuffled the steps here a bit and already filed a flock of follow up bugs. This bug still waits for the review on the source, but I wanted to give you a chance to take a headstart at the other pieces.

I'd like to add that the source doesn't need to be perfect and ready to ship, I just need to see something that technically and from a level of completeness enables me to vouch for your cvs access.
Axel,

Ok, Patipat will take care this issue.
it would be nice if we can have properties 'priority' and 'milestone' set here.

fyi, Thai team workspace is at
http://code.google.com/p/thai-l10n/source/checkout
Hi folks, we're still waiting for a source to make more progress here.

Reading comment 20, I'd like to point out that the source doesn't need to be final or anything, there's plenty of room to land fixes for QA feedback after setting things up in our repository.
Attached file Thai translated files
Axel,

Sorry for took it so long, the attached file is thai translated files, please check it out.
Please set the review flag on that attachment to '?' and enter my bugmail as requestee to put this into my review queue, thanks.
Attachment #330406 - Flags: review?(axel)
(In reply to comment #26)
> Please set the review flag on that attachment to '?' and enter my bugmail as
> requestee to put this into my review queue, thanks.
> 

done.

Comment on attachment 330406 [details]
Thai translated files

r=me. I did a few nits:

- removed UTF-7 from pipnss.properties
- reformatted bookmarks.html and switched links to th
- removed non-existing search plugin references, we'll do that in the search bug

The latest comparison run is at http://l10n.mozilla.org/buildbot/compare/linux-langpack/11530, which marks a missing file, th/extensions/reporter/chrome/reporterOverlay.properties, which I added. It's a rather empty file, so don't bother. The successful one is at http://l10n.mozilla.org/buildbot/compare/linux-langpack/11531 now, you can find the latest on http://l10n.mozilla.org/dashboard/. Tinderboxens are running on http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n-th and upload testing builds to http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/latest-mozilla1.9.0-l10n/.

More to come in the follow up bugs.
Attachment #330406 - Flags: review?(axel) → review+
http://wiki.mozilla.org/L10n:Localization_Teams updated, too, resolving FIXED.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
(In reply to comment #28)
> (From update of attachment 330406 [details])
> r=me. I did a few nits:
> 
> - removed UTF-7 from pipnss.properties
> - reformatted bookmarks.html and switched links to th
> - removed non-existing search plugin references, we'll do that in the search
> bug
> 
> The latest comparison run is at
> http://l10n.mozilla.org/buildbot/compare/linux-langpack/11530, which marks a
> missing file, th/extensions/reporter/chrome/reporterOverlay.properties, which I
> added. It's a rather empty file, so don't bother. The successful one is at
> http://l10n.mozilla.org/buildbot/compare/linux-langpack/11531 now, you can find
> the latest on http://l10n.mozilla.org/dashboard/. Tinderboxens are running on
> http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n-th and upload
> testing builds to
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/latest-mozilla1.9.0-l10n/.
> 
> More to come in the follow up bugs.
> 

So can I start testing and verification the translated strings on tinderbox?

and, once I get write permission on cvs, where can I test the new strings?
Yes, you can go ahead and start testing.

You can get to the current state of the sources via CVS, either by adding 
mk_add_options MOZ_CO_LOCALES=th
to your .mozconfig or directly via
cvs -z3 -d:pserver:anonymous@cvs-mirror.mozilla.org:/l10n co l10n/th

Once your account is up, you should add 

mk_add_options LOCALES_CVSROOT=kengggg%gmail.com@cvs.mozilla.org:/l10n

to your .mozconfig, that will use your account to check out l10n then. (Account name guessed.)
You need to log in before you can comment on or make changes to this bug.