If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash [@ nsPluginFile::FreePluginInfo] with Netopia eCare plugin installed

RESOLVED DUPLICATE of bug 350109

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 350109
12 years ago
6 years ago

People

(Reporter: Ed Gough, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs retesting on Mac with eCare plugin], crash signature)

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050608 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050608 Camino/0.8+

In build 0.9 Camino crashes upon trying to load www.applegeeks.com after eCare
plugin installed.

In build 0.8 and Firefox programs will crash on start after eCare plugin installed.

eCare plugin removed and builds are happy

Reproducible: Always

Steps to Reproduce:
1. Install netopia eCare
2. Restart OSX
3a. Run build 0.8.4 or Firefox - crashes.
3b. Run build 0.9
4. Go to www.applegeeks.com

Actual Results:  
Program quits. 50:50 will launch talkback agent

Expected Results:  
Program should load and display webpages.
Please attach a crash log to this bug using "Create a New Attachment" link and
post the Talkback IDs for the Camino 0.9 crashes. 

Updated

12 years ago
Keywords: crash
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Please attach a crash log to this bug using "Create a New Attachment" link and
> post the Talkback IDs for the Camino 0.9 crashes. 

I'll put eCare back and create the logs. It also does it on the Camino download
page.
(Reporter)

Comment 3

12 years ago
Created attachment 188017 [details]
System Crash Log
(Reporter)

Comment 4

12 years ago
Created attachment 188018 [details]
Copy of Crash Log OSX wants to send to Apple
(Reporter)

Comment 5

12 years ago
Attempted upload of eCare plugin failed. I will email it to any who request.
*** Bug 299438 has been marked as a duplicate of this bug. ***
-> Core Plugins
Assignee: pinkerton → nobody
Component: Plug-ins → Plug-ins
Product: Camino → Core
QA Contact: plugins
Version: unspecified → Trunk
Summary: Build 0.9 will run but crash on a certain webpage, Build 0.8.4 and Firefox will not run with Netopia eCare plugin installed. → Build 0.9 will run but crash on a certain webpage, Build 0.8.4 and Firefox will not run with Netopia eCare plugin installed. [@nsPluginFile::FreePluginInfo]
*** Bug 295257 has been marked as a duplicate of this bug. ***
Is this a dupe of bug 202619?

Comment 10

12 years ago
It might be related. I see the Adobe PDF viewer plugin in the loaded libs list.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 11

12 years ago
(In reply to comment #10)
> It might be related. I see the Adobe PDF viewer plugin in the loaded libs list.

It stops Camino from loading on Apples with the original installation of Adobe
on. I have played with the Apples at work and the only common factor is the plug in.
(Reporter)

Comment 12

12 years ago
Created attachment 191453 [details]
0.9a2 crash log

Updated

12 years ago
Attachment #191453 - Attachment mime type: application/octet-stream → text/plain
Summary: Build 0.9 will run but crash on a certain webpage, Build 0.8.4 and Firefox will not run with Netopia eCare plugin installed. [@nsPluginFile::FreePluginInfo] → crash [@ nsPluginFile::FreePluginInfo] with Netopia eCare plugin installed
FWIW, apparently there's also a "NPCardPrintingCarbon" plugin that crashes us in this same function; a guy on the forum was having crashes reminiscent of this bug and we helped him track it down to that plugin.

Comment 14

11 years ago
(In reply to comment #13)
> FWIW, apparently there's also a "NPCardPrintingCarbon" plugin that crashes us
> in this same function; a guy on the forum was having crashes reminiscent of
> this bug and we helped him track it down to that plugin.

His crashlog is at http://pastebin.mozilla.org/2842 for posterity, although someone should maybe upload that as an attachment here so it doesn't expire.

cl

Comment 15

11 years ago
Created attachment 251564 [details]
crash log from pastebin.m.o

I'm playing the role of "someone" today.

Comment 16

8 years ago
Does this crash still occur with up-to-date Firefox and eCare?
Whiteboard: [needs retesting on Mac with eCare plugin]

Comment 17

8 years ago
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/modules/plugin/base/src/nsPluginsDirDarwin.cpp&rev=1.14&mark=358,370,422,390-391#385
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 350109
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsPluginFile::FreePluginInfo]
You need to log in before you can comment on or make changes to this bug.