Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 74331
14 years ago
11 years ago

People

(Reporter: nigel_brooks, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

While the File Save As dialog is open, the downloads stop - and if you don't
clear the box quickly, then the downloads are dumped by the website and do not
continue.  There needs to be a LOT more use of multi-threading in FF !


Reproducible: Always

Comment 1

14 years ago
please provide more information.
A test URL?
Is this http or ftp?
How do you invoke the download?
What do you mean with "clear the box quickly"?
How is the download "dumped by the web site"?
Why do you refer to "multi-threading" as the cause of this problem?

Comment 2

14 years ago
Duplicate of (bug 273479->) Core bug 74331.
(Reporter)

Comment 3

14 years ago
A test URL? --- Any that provide a list of large files to download - most of my
examples are inside paysites, so they are of no use - you could try
www.wetlook.com/avi - run down the list, right-clicking, and saving, I find that
after 2 or 3 downloads are running, no more Save As boxes come up for a while...
then when 1 does, the downloads stop, and if you wait a while before clicking OK
to the Save As, then they don't complete.  However, you will probably need
larger files to try than these, as they are only a few MB, unless you slow your
link down to simulate a dialup.  I usually get the problem with 20-50MB files.

Is this http or ftp? --- http

How do you invoke the download? --- Just Right-click - Save As

What do you mean with "clear the box quickly"? --- Dismissing the dialog by
clicking OK.

How is the download "dumped by the web site"? --- After clicking OK on the Save
As dialog, when the download window redraws, some of the files have vanished,
and you are left with partially downloaded files.

Why do you refer to "multi-threading" as the cause of this problem? --- Because
the Save As dialog appears to be blocking the rest of the downloads, so I assmue
that it was part of the same download process, rather than part of the main FF
window process, otherwise I don't see why it should block it.  Also because I've
noticed a general 'locking up' problem in FF, where if a page 'stalls' it's
loading on one tab, all the FF windows lock up (I've not reported this yet, as
It's hard to tie down).
(Reporter)

Comment 4

14 years ago
I was asked for more info on this bug:

A test URL? --- Any that provide a list of large files to download - most of my
examples are inside paysites, so they are of no use - you could try
www.wetlook.com/avi - run down the list, right-clicking, and saving, I find that
after 2 or 3 downloads are running, no more Save As boxes come up for a
while...but keep right-clinking - Save As - FF queues them up...then when 1 does
appear, the downloads freeze, and if you wait a while (maybe several minutes -
depending I guess on the server's timeouts) before clicking OK to the Save As,
then they don't complete - wetlook.com seems able to recover even after several
minutes, but others abort the link.  However, you will probably need larger
files to try than these, as they are only a few MB, unless you slow your link
down to simulate a dialup.  I usually get the problem with 20-50MB files. It is
hard to start more than 2 downloads going at a time, and there doesn't appear to
be any logic as to when the next.

You can also see the effect immediately - start 1 download going, make the
downloads window visible, and check it's proceeding... then right-click and
bring up another Save-As dialog, but just leave it, don't click OK.  Watch the
download window - IT FREEZES !!!

Is this http or ftp? --- http

How do you invoke the download? --- Just Right-click - Save As

What do you mean with "clear the box quickly"? --- Dismissing the dialog by
clicking OK.

How is the download "dumped by the web site"? --- After clicking OK on the Save
As dialog, when the download window redraws, some of the files have vanished,
and you are left with partially downloaded files.

Why do you refer to "multi-threading" as the cause of this problem? --- Because
the Save As dialog appears to be blocking the rest of the downloads, so I assmue
that it was part of the same download process, rather than part of the main FF
window process, otherwise I don't see why it should block it.  Also because I've
noticed a general 'locking up' problem in FF, where if a page 'stalls' it's
loading on one tab, all the FF windows lock up (I've not reported this yet, as
It's hard to tie down).

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch

Comment 6

14 years ago
(In reply to comment #4)
> I was asked for more info on this bug:
> 
> A test URL? --- Any that provide a list of large files to download - most of my
> examples are inside paysites, so they are of no use - you could try
> www.wetlook.com/avi - run down the list, right-clicking, and saving, I find that
> after 2 or 3 downloads are running, no more Save As boxes come up for a
> while...

The bug is already duped but in case you were wondering about the effect you
describe above: Both the web server and a browser typically have limits in place
for the maximum number of connections per client. So it might be that the server
does not allow any new connections until you complete another file.
Alternatively you can change the max number of connections in Firefox, but the
default settings are quite fair. Increasing them blindly may not be appreciated
by all site owner's either.
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.