Unable to start the bugzilla testserver.pl on FreeBSD

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Bugzilla-General
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: cynosure_7410, Assigned: Dennis Melentyev)

Tracking

2.18.1
Bugzilla 2.20
x86
FreeBSD
Bug Flags:
approval +
approval2.20 +

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: 

dublin# ./testserver.pl http://www.localhost:9090/
TEST-WARNING Failed to find the GID for the 'httpd' process, unable
to validate webservergroup.
Use of uninitialized value in subroutine entry 
at /usr/local/lib/perl5/5.8.7/i386-freebsd/Socket.pm line 373.
Bad arg length for Socket::pack_sockaddr_in, length is 0, should be 4 
at /usr/local/lib/perl5/5.8.7/i386-freebsd/Socket.pm line 373.


Reproducible: Always

Steps to Reproduce:
1. ./testserver.pl http://www.localhost:9090/
2.
3.

Actual Results:  
Unable to get the Bugzilla running


Expected Results:  
It should be able to succesfuly start.

Comment 1

13 years ago
What version of Bugzilla are you using?
OS: other → FreeBSD
Summary: Unable to start the bugzilla testserver.pl → Unable to start the bugzilla testserver.pl on FreeBSD
(Reporter)

Comment 2

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
> Build Identifier: 
> dublin# ./testserver.pl http://www.localhost:9090/
> TEST-WARNING Failed to find the GID for the 'httpd' process, unable
> to validate webservergroup.
> Use of uninitialized value in subroutine entry 
> at /usr/local/lib/perl5/5.8.7/i386-freebsd/Socket.pm line 373.
> Bad arg length for Socket::pack_sockaddr_in, length is 0, should be 4 
> at /usr/local/lib/perl5/5.8.7/i386-freebsd/Socket.pm line 373.
> Reproducible: Always
> Steps to Reproduce:
> 1. ./testserver.pl http://www.localhost:9090/
> 2.
> 3.
> Actual Results:  
> Unable to get the Bugzilla running
> Expected Results:  
> It should be able to succesfuly start.

(In reply to comment #1)
> What version of Bugzilla are you using?

Bugzilla version 2.18.1.

Updated

13 years ago
Version: unspecified → 2.18.1
does www.localhost resolve?

Comment 4

12 years ago
Created attachment 195245 [details] [diff] [review]
This patch makes the testserver.pl script work on FreeBSD

The commands that are issued by the actual testserver.pl don't work on FreeBSD
because its 'ps' command doesn't have the 'gid' keyword (that is issued by the
script), but 'rgid' or 'pgid' only.
This way the script becomes compatible with both Linux and FreeBSD platforms
(haven't tested on Open/NetBSD).
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> Created an attachment (id=195245) [edit]
> This patch makes the testserver.pl script work on FreeBSD
> 
> The commands that are issued by the actual testserver.pl don't work on FreeBSD
> because its 'ps' command doesn't have the 'gid' keyword (that is issued by the
> script), but 'rgid' or 'pgid' only.
> This way the script becomes compatible with both Linux and FreeBSD platforms
> (haven't tested on Open/NetBSD).
As an additional comment, this patch only solve 'TEST-WARNING Failed to find the
GID for the 'httpd' process' part of this.

Comment 6

12 years ago
Dennis: You have to ask for review, when you post a patch!

http://www.bugzilla.org/docs/reviewer-list.html
Assignee: general → dennis.melentyev
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

12 years ago
Created attachment 195372 [details] [diff] [review]
Patch to allow  testserver.pl test apache group on FreeBSD

Well, since I surprisingly become an assignee, rework  Felipe Brant Scarel's
patch to be unified  diff.
See comments #4 and #5 for details on this particular patch. Actually, it
should be for ANOTHER new bug.
Attachment #195372 - Flags: review?(bugzilla)
(Assignee)

Updated

12 years ago
Attachment #195372 - Flags: review?(bugzilla) → review?(bugreport)

Updated

12 years ago
Attachment #195372 - Flags: review?(bugreport) → review+
(Assignee)

Comment 8

12 years ago
Seems like other part (original) of this bug is due to misconfigured installation.
If my patch would be approved, should we close the bug? And what resolution
should we use (WORKS4ME, INVALID, FIXED) if so?
Status: NEW → ASSIGNED

Comment 9

12 years ago
Yes.  This bug should just address the issue that is really in testserver.

If this goes in 2.20, please assign to someone that has 2.20 checkin permissions.
Flags: approval?
Flags: approval2.20?
Flags: approval?
Flags: approval2.20?
Flags: approval2.20+
Flags: approval+
Target Milestone: --- → Bugzilla 2.20

Comment 10

12 years ago
tip:

Checking in testserver.pl;
/cvsroot/mozilla/webtools/bugzilla/testserver.pl,v  <--  testserver.pl
new revision: 1.7; previous revision: 1.6
done

2.20rc2:

Checking in testserver.pl;
/cvsroot/mozilla/webtools/bugzilla/testserver.pl,v  <--  testserver.pl
new revision: 1.6.4.1; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.